Unable create Application Link from Confluence to JIRA

Hi Everyone,

I'm trying to create and application link from Confluence to JIRA. I recieve the following error: The application at URL ''http://xxxx:8080'' is not responding. Please confirm that you want to use this URL.

Both JIRA and Confluence are running on the same machine using different ports. I have performed the following troubleshooting steps (RHEL Linux):

1. Verified SSL Cert. I'm NOT using a self signed certificate (Thwate).

2. Verified URL is in /etc/hosts file. Can ping itself, etc.

3. Each service is running and has been in use for several months.

4. Disabled firewall.

Any thoughts?

8 answers

0 vote

Hi there,

What about try links both applications using http://IP:PORTto see any result ? Make sure you had update the Base URL on both side.

Regards,

JC

Hi JC,

I tried using the IP:PORT earlier (unsucessful), however I didn't change the base URL. Will changing the base URL affect the application at all?

I have the exact situation. Both sites on one machine. Jira redirecting to 8443 and https with Confluence at 8090 on standard http. Fireall and SELinux are off.

It looks like the Jira sites link is set up correctly (at least it doesn't complain when I configure it but the Confluence site can't see the jira site at all whether I use name:port or IP:port.

I did upgrade from Jira 5.1.4-> 6.2 and Confluence from 4.5 -> 5.5 and now I can't recreate the link between the two. This worked famously before the upgrade and I can log into Confluence with the administrator account.

Any thoughts?

I have the same exact problem, i was able to see all jira reports from confluence but not anymore, i started to have this problem after i updated both apps plugins.. and before that i downloaded and removed inproduct plugin, i started to have problems eversince... The linking method im using is ip:port both on standard http Any ideas?

Hi. What was your final fix for this problem? Thank you

I have the same problem with confluence 5.7 and Jira 6.3 am using ssl for boht confluence and JIRA

Although I had definately enabled RPC and Soap in Confluence I found that this had turned off.

Go to hte Admin cog and select General Configuration. Select Further Configuration on the left and check that Remote API (XML-RPC & SOAP) is checked.

I had the same issue - remove any application links on both sides and stopping and starting the JIRA service fixed it.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,097 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you