UPM disabled the Bob Swift Software - Table Plugin overnight and now it will not let me enable or uninstall the plugin

Hi,

I am running a staging environment with Confluence (4.3) and Zen Foundation (5.2.4) installed. I installed the Bob Swift Software - Table Plugin v5.0.2 a few weeks ago and have been using it without issue up until the beginning of this week.

On Monday I realized the UPM had disabled the Table Plugin overnight and when I tried to re-enable it it showed this error: Failed to enable plugin Bob Swift Software - Table Plugin (org.swift.confluence.table).

Then I tried to uninstall the macro and re-install, but it will not let me uninstall it either giving me this error: Object of class com.atlassian.confluence.plugin.persistence.PluginData with identifier org.swift.confluence.table: not found

Do you know what might be causing this problem?

Thanks,

Dan

3 answers

Are you operating with an eval? perhaps it expired?

Try an uninstall, clean restart, reinstall cycle.

Additionally, there could be another third-pary plugin that is interfering with Table Plugin and causing it to be disabled. Try to temporarily enable Plugin Safe Mode and check again if it makes any difference. This will disabled all user-installed plugins at once. So if the issue does not occur again, it is caused by one of the third-party plugins installed. In order to isolate whichplugin is the culprit, you may need to enable the plugin one-by-one till you observed the issue arise again. This may need to be done during non-peak hours as disabling third-party plugins would cause users unable to perform some operations provided by those plugins. Once the test has been carried out, disable this mode.

If that didn't help, you could run the following query against Confluence database to check if the plugin is disabled:

select * from BANDANA where BANDANAKEY='plugin.manager.state.Map';

And if it is, you coud manually enable the plugin through the database. Detailed steps can be found in the Resolution section #2 in this KB: https://confluence.atlassian.com/display/CONFKB/Error+rendering+WebPanel%3A+No+renderer+found+for+resource+type

NOTE: Please backup your database before proceeding

Hi Andy,

I have a fully licensed version and it says it's still licensed in the admin section.

It still wont let me uninstall the plugin it keeps coming up with the same error: "Object of class com.atlassian.confluence.plugin.persistence.PluginData with identifier". The enable/disable button is not visible anymore.

Hi Hanis,

I tried using safe mode and it still will not allow me to enable/disable or uninstall the plugin.

I will try your other suggestion and see what comes up.

Thanks for the suggestions!

Daniel

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

743 views 21 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you