Turkish Character Support

I've installed confluence4.2 on my server.

When I entered any Turkish character(like ç, ö, ş,ğ) in confluence it shows me ? instead of Turkish characters. However, this attitude is not stable, when i refresh the page, sometimes it shows me Turkish characters.

I've opened a database in UTF8 collation and my database script has useUnicode=true&characterEncoding=utf8 in URL.

Do you have any suggestions to solve this problem?

1 answer

1 accepted

I solved my problem. It was about database collation. I noticed that collation is utf8_general_ci instead of utf8_bin.

Zafer bey merhabalar,

bu sorunu aştığınızı görüyorum bende aynı sorunu yaşamaktayım fakat mysql tarafına çok hakim değilim acaba varolan database collation yapısını nasıl değiştirebilirim

Çok teşekkür ederim Zafer bey sorun tamamen çözüldü.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted 3 hours ago in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

25 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you