Turkish Character Support

I've installed confluence4.2 on my server.

When I entered any Turkish character(like ç, ö, ş,ğ) in confluence it shows me ? instead of Turkish characters. However, this attitude is not stable, when i refresh the page, sometimes it shows me Turkish characters.

I've opened a database in UTF8 collation and my database script has useUnicode=true&characterEncoding=utf8 in URL.

Do you have any suggestions to solve this problem?

1 answer

1 accepted

Accepted Answer
0 votes

I solved my problem. It was about database collation. I noticed that collation is utf8_general_ci instead of utf8_bin.

Zafer bey merhabalar,

bu sorunu aştığınızı görüyorum bende aynı sorunu yaşamaktayım fakat mysql tarafına çok hakim değilim acaba varolan database collation yapısını nasıl değiştirebilirim

Çok teşekkür ederim Zafer bey sorun tamamen çözüldü.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 09, 2018 in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

376 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you