The Share on Confluence bookmarklet says I (the admin) am not allowed to share.

How do I get the share bookmarklet to work? It's essential that my team be able to share links quickly, on Confluence Cloud. I am the admin of the site.

Screen Shot 2017-07-05 at 11.38.28 AM.png

Very frustrated,

Javier

2 answers

0 votes
Ann Worley Atlassian Team Jul 05, 2017

Is your use case consistent with what is being described in this bug report?

Unable to use "Share a Link" functionality of Share Link blueprint if user has access to a single space and that space is a favourite

In other words, is the space a favorite for your profile? I tested on my Confluence Cloud test instance and could not reproduce the issue, even when my test user had access to only one space and that space was a favorite. However, the bug is in open status so you could be impacted by it.

I see. Once I removed all Spaces from favorites, the bookmarklet worked. Thanks!

Ann Worley Atlassian Team Jul 05, 2017

That's great news! Thanks for following up to let the Community know what worked for you.

@Ann Worley The work around mentioned here (i.e. to unfavourite) doesn't work for me. Can you please follow up with the development team regarding https://jira.atlassian.com/browse/CONFCLOUD-54052

Why is there no update (or fix) even after a year ?

Ann Worley Atlassian Team Jan 08, 2018

I am not sure why the bug has not been fixed in a year, it is probably due to a condition covered in our Bug Fixing Policy. If I had to speculate I would say the fact that there is a workaround and not a lot of votes contribute to it's being lower in priority.

I did ping the dev team, and by commenting on the bug you also communicated directly with them as the ticket is in their Jira instance.

I will keep an eye on the bug and this thread and follow up if needed.

@Ann Worley Thank you for the reply. I understand that some workaround exist. Probably there are workarounds for most bugs out there. But, this is a feature aimed primarily at improving usability and hence having to use a work around takes away it's charm. Also, I consider Atlassian to be a great software vendor not simply a good one. So if you ask me, despite the work around the bug is still critical.

had the same issue in german language on the cloud version of confluence. Situation was similar with one space (and on favorites). Removed the space from favorites and the bookmarklet worked as intented and known with on-premise-version.

tested several different space setups and it turns out that at least one space must not be on favorites for the bookmarklet to work. If no "non-favorite" (global) space exists, the bookmarklet pops the error.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

310 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you