Test confluence pointing to production

I stood up a test confluence site. I can log into the system from the server but not the confluence login. It seems that the website points me to the production system. Are there any files I can manually edit to point the test server to the test suite and not production? Thank you in advance.

6 answers

This widget could not be displayed.

Hello David,

first of all check, your BASE URL, if it is the same as production it can address you to use prod instead of staging.

Another check, atinstallation level, is to verify your confluence home location in <CONFLUNECE INST>/confluence/WEB-INF/classes/confluence-init.properties

Hope this helps,

Fabio

This widget could not be displayed.

I have searched for the file to change the base URL and have no idea what I will need to be changed. I am also copying you what my confluence-init.properties looks like.

###########################
# Note for Unix Users #
###########################
# - For example:
confluence.home = /opt/atlassian/confluence
#
# NOTE: If the path of your confluence.home directory contains symlinks,
# please set confluence.home to the absolute path, otherwise problems may occur.

# - For example:
confluence.home = /opt/atlassian/confluence
# should be written as:
confluence.home = /opt/atlassian/confluence

###########################
# Configuration Directory #
###########################

# specify your directory below (don't forget to remove the '#' in front)

confluence.home = /opt/atlassian/confluence

This widget could not be displayed.

Should be the base URL.

This widget could not be displayed.

Hello David,

your BASE URL should point to your staging env.

Another check is the db linked into your STAGING Confluence Home. The related file is confluence.cfg.xml

Please make sure that your are pointing to Staging Database.

Regards,

Fabio

This widget could not be displayed.

It seems that the base URL is correct and so I'm not sure where I it is getting its data. if I try to reset my password on test it points me to the production server.

This widget could not be displayed.

If the base URL is correct, check if you have a proxyName configured in the server.xml. You can also check if you have any apache redirection enabled.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Tuesday in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

108 views 12 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you