Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Tend to upgrade from 5.97 to 5.10 before move to Cloud

During upgrade, I got these error while restarting Confluence:

Wonder if anyone can help? Thanks a lot.

Caused by: org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist
Caused by: com.atlassian.config.ConfigurationException: Cannot update schema
Caused by: net.sf.hibernate.HibernateException: org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist
Caused by: org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist
Caused by: org.postgresql.util.PSQLException: ERROR: relation "scheduler_clustered_jobs" does not exist
Caused by: com.atlassian.activeobjects.internal.ActiveObjectsInitException: bundle [com.atlassian.plugins.atlassian-whitelist-core-plugin]
Caused by: java.lang.RuntimeException: Could not get unique fields for table 'AO_21D670_WHITELIST_RULES'
Caused by: org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist
Caused by: com.atlassian.activeobjects.internal.ActiveObjectsInitException: bundle [com.atlassian.confluence.plugins.confluence-feature-discovery-plugin]
Caused by: java.lang.RuntimeException: Could not get unique fields for table 'AO_6384AB_DISCOVERED'
Caused by: org.postgresql.util.PSQLException: ERROR: column am.amcanorder does not exist

1 answer

0 votes
Pavel Junek Community Leader Mar 15, 2021

Hi @Bruce Yen,

What version of PostgreSQL do you have? Confluence 5.10 is only compatible with PostgreSQL 9.2 and 9.3. Maybe this KB article will help you CONFSERVER-44216 

Cheers

Pavel

Thanks for replying. 

We are using 9.6.2 (on AWS RDS).

But 5.9.7 works with this version. But 5.10.0 doesn't? I'm confused.

Thanks again.

Pavel Junek Community Leader Mar 15, 2021

Yes, something may not work properly.

For each version of Confluence you need to look at Supported Platforms. According to the article https://jira.atlassian.com/browse/CONFSERVER-44216 should help upgrade the PostgreSQL driver.

Pavel

All right. I'll follow the instruction and add this new latest jdbc drive.

If possible, please don't close this thread. Because this problem has bothered us for a while.

Also, if we are converting Cloud version. Do we really need to get our 5.9.7 to 5.10.0 before we can do that? Can you confirm this? Or we don't need this step?

Thanks again. Much appreciated!

Sorry. But the PostgreSQL will still be at version 9.6.2, which, according to the doc., is not compatible with Confluence 5.10? 

The new PG jdbc drive would fix this problem? I'm lost.

Thanks.

I used the jdbc drive: postgresql-42.2.18.jar, which worked with previous version: 5.9.6 to replace postgresql-9.2-1002.jdbc4.jar.

It works!!! Now, my Confluence is running 5.10.0.

Next is to convert it to Cloud hosting.

Thanks a lot for help resolved this issue.

After restarted the server the 2nd time, I got this error:

Confluence cluster node will not start up because the build number in the database [6214] doesn't match either the application build number [6441] or the home directory build number [6441].

Can you help, please?

Thanks. 

Pavel Junek Community Leader Mar 16, 2021

Hi Bruce,

Thank you for the information.

I'm glad we managed to upgrade Confluence. Otherwise, you need Confuence 5.10 or earlier to migrate to Atlassian Confluence Cloud.

To your error - you can try this Atlassian KB to resolve this issue.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

⚡️NEW Group for Confluence Cloud Admins

Calling all Confluence Cloud Admins!  We created a new Community Group to support your unique needs as Confluence admins. This is a group where you can ask questions, access resou...

144 views 2 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you