Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,138
Community Members
 
Community Events
176
Community Groups

Template with variables and expand created automatically

Hi there.

I created a page template that includes "Expand" sections and "Variables".

When I create a new page and apply the template, I get to a page saying "This template uses variable. Once you fill them in, etc".

 

However, as soon as I expand a section to add information, it's like I'm clicking on the Create button, and I am in the editor. I cannot see the variables there, so my variable fields are pointless.

 

Any idea what's going on here?

2 answers

I had the same issue with variables, but I think I may have solved it. It looks like the documentation may be out of date.

I used the variable macro /variable to create the variable and expand the variable in other parts of the document. My template looks something like the following.

My Page

[my_variable | text]

Other section

[my_variable | text]

 

When I created the document, I got the same message about using templates in the document as describe above. I was able to input the variable. The change was reflected in both instance of the document. I clicked the Create Document button. The values were visible and in their proper places.

  

Marcel Neufert Community Leader Nov 30, 2021

Hi @Scott Purcell

I understand that you have solved this issue.
Unfortunately I do not understand how you did it. 
Can you please describe your solution?

I want to include the variables in the expanded content.

Thanks & kind regard,

Marcel

Hi @Marcel Neufert 

I'll do my best. The solution is not intuitive.

First create a template with variables and an expandable section:

template-add-vars-and-expandable.PNG

The variables have to be created outside of the expandable section. In the above image, I created them above the expandable section. Then I copied them into the expandable section.

After the template is saved, create a new page using the template:

create-page-using-template.PNG

After selecting the template, in this case Page with parameters, Confluence will create a page for you to input values:

new-page-before-vars.PNG

Enter the values and create the page:

new-page-afters-vars.PNG

The create button is not in the image, but on my browser at the bottom of the screen. The page looks like the following.

create-page-complete.PNG

Note that the variables are no longer available after the page is created.

I hope that helps!

Like Marcel Neufert likes this
Marcel Neufert Community Leader Dec 02, 2021

Thank you very much! It is at least a workaround. Cause I do not need the variables above the expandable section.

Thanks a lot for your very detailed description!
I reported the bug to Atlassian and they created a bug-ticket here:

https://jira.atlassian.com/browse/CONFCLOUD-73246

Kind regards,
Marcel

I'm glad I could help!

I'm experiencing the same issue. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events