Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,231
Community Members
 
Community Events
165
Community Groups

Table of Contents does not appear on published page

Hi

Working on a basic page. When I add the ToC it finds the headings as expected. But when I publish the page the ToC blinks rapidly and disappears. Screenshots below. Am I missing a step? Im on Chrome on a mac, if that matters.

thanks

Devin

 

ToC on page in Edit mode

Screen Shot 2020-08-07 at 10.00.43 PM.png

 

Toc finds headings

 

Screen Shot 2020-08-07 at 10.00.29 PM.png

 

ToC disappears when page is published

 

Screen Shot 2020-08-07 at 10.00.52 PM.png

 

 

15 answers

Hey hey - I'm glad I'm not the only one having this problem. 

I've tried copying the content to a new page (I'm having the same issue on 2 new pages anyway), and I've also tried in Chrome and Safari - but still no luck.

Any other tips? I sure would appreciate it!

James

For anyone on Confluence Cloud.....  I just received the following response from Atlassian Support related to this issue.

We've received a few tickets from other users, reporting the exact same behavior. Upon further investigating this, we identified the root cause to be related to a bug that recently emerged on Confluence. This bug is already being investigated by our developers and being tracked internally with high priority. All updates on its resolution will be provided through the public bug report below:

 I added an internal comment linking this ticket to the bug report.
 At the moment, we can't set an ETA for the fix to be released, since it will depend on the team's backlog and the bug's complexity. Since all further information will be given through the bug report, we suggest you to add yourself as a watcher on the report to receive an e-mail notification when this issue gets fixed by our dev team. Also, feel free to comment, and do not forget to vote for this issue by clicking on This affects my team.

Thank you for this.
Do you know if its still an issue as mine doesnt show either

I'm having exactly the same issue as reported before. I'm also using a Mac+Chrome configuration. Please Atlassian Support, prioritise and check this issue. 

I am also experiencing the same issue.

I'm experiencing the same issue.

Two different pages, tested in both Chrome and Safari on Mac - no luck.

Jay

Using windows / chrome and same happened. It is  a shame that is impossible to do such a simple thing on confluence.

Same here.
In Confluence page looks good, but published page - is empty.
No errors appear in any step.

By the way, I use Mozilla and Windows.

Hi @Devin Vail 

It sounds like there's something specific on that page which is causing an issue. If the page isn't too big, then I'd suggest manually copying (i.e. Ctrl+A, Ctrl+C) all the content to a new page and saving it and see if you are seeing the issue in other Confluence page or space.

Are there any headings on the current Confluence page where the macro was added?

Does this happen when you use a different browser?

 

Thanks,
Manisha

Good call Manisha! Tried in Safari and it works perfectly - so its not the page or macro that are the problem.

The new issue is that it doesn't work in Chrome in a mac? Its my browser of choice, which Im sure is the case for many others. How could this be addressed in your opinion? Some kind of support ticket with Atlasssian?

thanks!

Devin

Hi @Devin Vail 

Glad to know that it works for you in safari. But we are not seeing any issue with the Chrome browser on Mac as well. Can you please try it in other Confluence space in the Chrome browser and verify it.

 

Thanks,
Manisha

Hi @Manisha Kharga _Appfire_ 

I have the exact same issue, same configuration, mac + chrome, does not show the TOC when I preview

Same issue here, but it does not work in Safari either for me.

@Devin VailIt's a bug.  Atlassian is aware of the issue.  CONFCLOUD-73922: Table of Contents macro disappears upon refreshing the page  Go to the ticket, watch it, and click the link that it affects your team.  We need to ALL show our support, watch, comment, etc., to get development to focus on our issues.

I have been seeing this issue across various pages on my company confluence instance as well. I removed any local site data associated with Atlassian to make sure it wasn't a local issue. 

I would prefer not to have to re-create pages since I've been seeing it happen in different places, so an Atlassian-side fix is preferable.

There's various warning and errors in my chrome javascript console, maybe one of them will point to the cause:

https://gist.github.com/rsheyd/8761c4530a8739e2a18c8c8ed73a5f74

I discovered this is happening on ALL pages in my site that are using the ToC macro.  I even created a new page with ONLY 3 lines formatted as headers with a ToC macro.  Same behavior in every browser!  The Table of Contents appears when the page is first loaded, but if you refresh the page, the ToC disappears.  I can actually see it appear and then vanish when the page reloads.  I opened a ticket to Atlassian Support on this.  If you're using Cloud, I'll post here what happens.

I just experienced this same thing in Confluence Cloud and trying to find a solution.  Very odd.  Table of Contents appears when the page first loads, and then disappears.  Very frustrating.

I removed a hpyer link at the top and it worked.

I found the same issue, but I made toc following support instruction. But when I publish the page, toc appears. 
so in edit and preview you may not see table of contents

I am using  macOS Big Sur and Chrome and facing same issue with TOC not showing up after publishing the page. I saw someone suggested removing links, but this page does not work without links on this page. 

Would you be able to share the instruction by any chance? 

I'm also experiencing the same issue.  I'm using Chrome Version 89.0.4389.72 (Official Build) beta (x86_64) on macOS Big Sur 11.2.3.

In my case somehow it happened because of link.
Just ordinary link to other page was inserted on same page.

After removing link, content is displayed.
Can not imagine how it can be related, but it worked.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

260 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you