It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Something went wrong after loading the editor.

At one point I was able to create and edit however I am getting message ' Something went wrong after loading the editor. Copy your unsaved changes and refresh the page to keep editing.'

Tried on 3 browsers, cleared cache and cookies, updated Java, restarted PC, had profile removed and re added and it looks like I am the only one in the group getting this error.

 

Tried to refresh page while receiving error in multiple browsers.

 

PC is Windows 10 Pro build 18363.720.

 

Does anyone have any other suggestions?

 

Thanks in advance.

1 answer

Hi Jason,

Is collaborative editing enabled in confluence?

Are you accessing Confluence in a different way to how your colleagues are accessing i.e. Different VPN, in a different office, different network? 

Regards

Evan 

Hi Evan,

 

By collaborative, is that something I can check on the client side? It should be.

 

We should all be using the same VPN to connect remotely. Main difference for me is I only noticed this happening when working away from the office however my colleagues are as well now. 

 

Thanks for reaching out to me.

 

Kind regards,

 

Jason

If collaborative editing is enabled you should see when editing a page that two or more people can edit a page at the same time, see the below example. 

collab.png

Does this look familiar? I know you can't go and check this at the moment but if your not an admin you could ask a colleague to check if they get a similar layout to the above.

If you are an admin in confluence you can also check in settings -> General configuration -> Collaborative editing. It will show as either on or off.

 

My thinking was the way you connect is different, its possible that websockets are blocked on the route you are connecting which would mean collaborative editing won't work and you would get an error similar to ' Something went wrong after loading the editor. Copy your unsaved changes and refresh the page to keep editing.'

If you can confirm if collaborative editing is on or off we can decide what the next test  / steps are.

Thanks. I asked the admin to check and that looks to be fine.

 

I also failed to mentioned I clicked on the websocket link it the connection appears to be fine as well.

 

Kind regards,

 

Jason

Also it does not seem to matter if I edit or create, the same message appears.

We are experiencing issues at my company too, both collaborative editing and just one person editing, but only on pages that use the new confluence format.  2020-03-26_13-44-24.png

Try opening Developer Tools in Chrome (or the equivalent in whatever browser you use) and reproduce the issue

Look for any errors in the console output that might show what the problem is.

Failed to load resource: the server responded with a status of 403 ()

Failed to load resource: the server responded with a status of 409 ()

Failed to load resource: the server responded with a status of 404 ()

 

Uncaught TypeError: Cannot read property 'forPlugin' of undefined
at shouldShowFeatureDiscovery (batch.js?externals=__local-default__&locale=en-US:320)
at enableWebItem (batch.js?externals=__local-default__&locale=en-US:271)
at Object.success (batch.js?externals=__local-default__&locale=en-US:420)
at p (jquery.js:1086)
at Object.fireWith [as resolveWith] (jquery.js:1204)
at y (jquery.js:7565)
at XMLHttpRequest.t (jquery.js:8358)

 

Failed to load resource: the server responded with a status of 401 ()

Failed to load resource: the server responded with a status of 500 ()

 

cfetch.ts:44 PUT https://companyname.atlassian.net/wiki/rest/api/content/320372815/?status=draft&action=publish 500

 u@cfetch.ts:44
 (anonymous)@request-helper.js:159
 (anonymous)@PreloadedRestLink.ts:15
 b@request-helper.js:165
 put@request-helper.js:339
 publishEditorPage@content.js:535
 (anonymous)@api.js:46
 (anonymous)@index.js:14
 publishEditorContent@ContentEditorBindings.ts:124
 (anonymous)@ContentEditorBindingsComponent.tsx:386
 Promise.then (async)  
 (anonymous)@ContentEditorBindingsComponent.tsx:348
 (anonymous)@FullPageEditorComponent.tsx:560
 e.reduce.Object.<computed>@AnalyticsContextConsumer.js:48
 s@react-dom.production.min.js:14
 d@react-dom.production.min.js:15
 (anonymous)@react-dom.production.min.js:15
 k@react-dom.production.min.js:17
 C@react-dom.production.min.js:18
 T@react-dom.production.min.js:18
 P@react-dom.production.min.js:21
 Sn@react-dom.production.min.js:84
 ju@react-dom.production.min.js:250
 Fe@react-dom.production.min.js:39
 Cn@react-dom.production.min.js:86
 (anonymous)@react-dom.production.min.js:251
 t.unstable_runWithPriority@scheduler.production.min.js:18
 Iu@react-dom.production.min.js:251
 In@react-dom.production.min.js:85

What add-ons do you have installed?

On my browser?  None.

Sorry I meant in confluence. Does this affect just you or everyone?

I'm trying to find out what, if any, Add-ons we are using.  This is affecting everyone, yes - but not on all pages.  The particular page we are struggling with is in the new page format Confluence has recently made available.  Pages using the old format seem to be fine.

By the way, do you have any other suggestions concerning the issue I am running into?

 

Kind regards,

 

Jason

@Jason Upton - Did you manage to confirm if collaborative editing is on?

Yes it is and thanks.

You could see if its possible to turn off collaborative editing temporarily whilst you test if you get the problem when its off. 

Are you using the same VPN profile as your colleagues? Do they get the same problem on the same VPN profile as you? Is it possible for a colleague to login on your computer and they get the same problem? Can you login on a colleagues computer and get the same problem?

Regards

Evan

Have it turned off for me only?

 

Yes same VPN profile. I am the only one having this issue.I do not think it is possible to have some one log on  however is so as in windows rdp or any lremote app?

 

Thanks again,

Jason

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

5,345 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you