Setting up 8443 to 443

How can I change 8443 to redirect to 443.? I have followed the documentation and its still not working.

3 answers

1 accepted

1 vote

Hey Tameika,

On the server.xml, try the following parameters:

<Server port="8000" shutdown="SHUTDOWN" debug="0">
    <Service name="Tomcat-Standalone">
        <Connector port="8090" connectionTimeout="20000" redirectPort="443"
                maxThreads="200" minSpareThreads="10"
                enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8" />
        <Engine name="Standalone" defaultHost="localhost" debug="0">
            <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false">
                <Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
                    <!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
                    <Manager pathname="" />
                </Context>
            </Host>
        </Engine>
        <!--
            To run Confluence via HTTPS:
             * Uncomment the Connector below
             * Execute:
                 %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA (Windows)
                 $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA  (Unix)
               with a password value of "changeit" for both the certificate and the keystore itself.
             * Restart and visit https://localhost:8443/
             For more info, see https://confluence.atlassian.com/display/DOC/Running+Confluence+Over+SSL+or+HTTPS
        -->

        <Connector port="443" maxHttpHeaderSize="8192"
                   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" scheme="https" secure="true"
                   clientAuth="false" sslProtocol="TLS" SSLEnabled="true"
                   URIEncoding="UTF-8" keystorePass="changeit"
                   keystoreFile="<keystoreLocation_path>"/>

 

The SSL will be set in Tomcat with this configuration, and not in Apache so you don't have to edit anything in mod_proxy or mod_ssl.

Cheers,

So if I want to set this in Apache I know I would have to set the certfile in the ssl.conf file. But then I would also have to do the following correct: <VirtualHost *:443> ServerName confluence ProxyRequests Off <Proxy *> Order deny,allow Allow from all </Proxy> #SSLEngine on #SSLProxyEngine On ProxyPreserveHost On ProxyPass "/" "https://confluence:8443/"; ProxyPassReverse "/" "https://confluence:8443"; DocumentRoot /var/www <Directory /var/www> Options -Indexes Order allow,deny Allow from all </Directory> </VirtualHost>

0 vote

What documentation, and how are you doing this?  There are a number of ways to do it - proxies, Tomcat settings and firewall rules are the most common, but which one are you using?

I am following this as documentation

https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html

SSLEngine On errors out on Centos 7.2

mod_ssl is installed and mod_proxy

So that could be a problem because maybe SSLEngine needs be on

 

I have another one that I am looking at but I have the weblink at work

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,798 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you