Searching for labels with hyphens in them

I have labels of the form word1-word2-word3 on my pages, and I want to search for them.

Using labelText:word1* as a search term finds those starting with word1, but labelText:word1\-* (escaping the hyphen) finds nothing.

I would like to do a search for labels starting with word1 and ending with word3, but labelText word1*word3 finds nothing. This works OK for labels without hyphens in them.

This is in Confluence 5. Any suggestions, please?

1 answer

I realised this affects searches in general and not just labels. It seems this has been broken for a very long time: https://jira.atlassian.com/browse/CONF-3036

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

1,040 views 23 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you