Search Index Always Needs Manually Rebuilding

No matter what we try our queue never optimizes itself anymore, so we always need to rebuild the search index manually. Support said our JVM heapsizes look fine based on our usage, and I've taken the steps to recreate the index from scratch. This fix seems to work for a week or so, but eventually we have to start rebuilding the search index everyday. Here is a screenshot taken on 6/27 (I've had to rebuild the search queue manually everyday since):

We're currently running Confluence 4.1.7 on a RHEL 6.2 VM server, with 4GBs of RAM. We may get a dozen updates per day. Any info that could lead us to a permanent solution would be highly appreciated.

1 answer

This widget could not be displayed.
Have you checked the scheduled jobs for flushing the index queue? Details here: https://confluence.atlassian.com/display/DOC/Scheduled+Jobs. According to the docs the default interval is 1 minute, so if this is the case and the job is failing you'll have some idea of what is going wrong thanks to the entries in the log file. What database are you running Confluence on?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

464 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you