Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Save does not work in draw.io in Confluence

I tried to add a draw.io diagram to one of my wiki pages, after drawing my diagram, I hit "save", entered a name for my diagram, and then it brought me back to my diagram (no error or any indication of anything amiss).  I then hit "exit".  It warned me that my changes would be lost.  I figured this was a spurious error, but after hitting "ok", my diagram was, indeed, entirely lost.

I have tried this in two web browsers Firefox (38.0.5) and Chrome (43.0.2357.134) on a Fedora 20 Linux workstation, and on Chrome on a Windows VM all with the same results.  However, a co-worker was able to create a draw.io diagram on the same page with no issue.

I tried looking at the web console when I did a save, and saw this error message: "TypeError: b is null  mxEditor.js:1:4293"

13 answers

Is this Confluence Cloud or Server? If server, which version of Confluence and which version of the plugin please?

Confluence says Atlassian Confluence 5.7.3, Draw.io says it is v 5.1.0.0.

It's too recent that there's any issue with the draw.io version. Do you simply lack permission to write attachments on that page?

Had the same problem on my cloud space today. Save diagram, dialogue appears, entered a title for the diagram, hit save, no diagram showed up in the blank page, work was completely lost.

Atlassian Confluence Cloud, Mac OSX El Capitan, Chrome latest.

Hi Konrad, thanks for the report. Would you mind opening a new thread and linking to it please? The original report is on Confluence Server. Confluence Cloud shares no integration code with the server version, any issue with saving cannot be related. It helps us to have one issue per thread, thanks.

Also, could you please email support@draw.io with your IP address and URL of your atlassian.net installation? (Additional thread isn't really needed, thinking about it).

Hi @David Benson [draw.io],

We see this error as well. For the page where this error is occurring, there is no restrictions applied. Also, the space has permissions for add attachments for the user who is trying to save this diagram, but there is no delete attachments permissions provided to that user. This space is of documentation theme.

Another interesting point is that, the same user is able to save the diagram in another page. This space is of a different theme. But the space permissions are same as with the above page.

Thanks

Please open a new thread with the "addon-com.mxgraph.confluence.plugins.diagramly" tag.

I should have mentioned how I got around this problem:  I discovered that other users were unaffected, and other pages were also unaffected, so I concluded it was something funky about this one page.  I made a copy of the page, and voila! it worked fine.  Not sure what the actual problem was, I could probably methodically remove things from the page until it works again... but that's no substitute for the drawing pluging properly detecting and reporting errors.

Same thing happened to me, a year later now. Spent two hours creating drawing, saved drawing, saved confluence page, drawing vanished. Went back, created a "test diagram" – one box – saved, saved, drawing vanished. Using Cloud.

 

The App needs to be flagged with a warning for users.

This thread is about Confluence Server, not Cloud, btw, it's not the same issue.

This thread is about Confluence Server, not Cloud, btw, it's not the same issue.

Then again, another 4 years later.

The same errors are still there.

Server, not cloud btw ....!!

Unbelievable. What a crap. I was drawing for an hour....saved the drawing, its still there, but when reloading the page the drawing was reset to the previous drawing. This thing seems to have issues when you try to update already existing drawings, what a crap.

It's not the same error. It might be the same result, but the codebases have nothing in common.

What are you talking about. My problem is with confluence server. As you said above, this thread is about confluence server, not cloud.

Nevertheless, there are no bugs that we have left unsolved for anything remotely like 4 years. Your problem could be as simple an attachment write permission. But since you don't seem to be willing to engage in a professional manner, I think best to leave the subject.

Julian I'm New Here Sep 10, 2020

Hi, 

I just had this same issue. That is, my updates to a drawing were not shown but two attachments appeared. II found this via a bing search. I followed the guidance (see below) and copied the page which seemingly resolved the issue.

Trent Fisher Jan 20, 2016

I should have mentioned how I got around this problem:  I discovered that other users were unaffected, and other pages were also unaffected, so I concluded it was something funky about this one page.  I made a copy of the page, and voila! it worked fine.  

I just saw your other response about this issue and realized I missed your previous question.  The page where I was adding the diagram was, I believe, added by me.  But I did check the permissions at the time and I could see no difference between the original and the new one I added per my workaround.  It seemed to me there was some unseen setting on that page which caused the error.

Unfortunately, that original page seems to have been deleted by an overzealous team member, so I cannot investigate this further.  This problem has not occurred again on any other pages.

I wish I could help further.  Though it would be nice if the error I noticed on my web console would get caught and a proper error message propagated to the user.

Thanks for coming back to me Trent. This really is the problem, it's a very rare bug, but very annoying when it happens and very tough to recreate smile.

We don't show users errors since it causes more confusion than help in most cases. We do log them when they happen, but sometimes, as is the case here, we need a little more context to understand why this might happen (i.e. checking for null isn't enough).

I'll take another look at that line from the release at the time, since it's the best lead we have to date.

 

Oh, this is Confluence server, sorry. Greg is using Cloud, it's a different issue smile.

I resolved this problem with a draw.io diagram hosted on Confluence Server. 

I found the missing diagram saved as an attachment to my post. (If you click the three-dot menu (. . .) "Attachments" is near the top, right after "Approval History." 

I was able to put the diagram back where I wanted it by clicking the icon to insert a photo. The dialogue box offered my diagram as a selection. I also had to select a button to make it full sized, but it went back into the page exactly as before. 

I had the same issue, created a new page, published it, inserted a DrawIO diagram and worked on it for quite a while before finally publishing it. End result: no diagram.

Thanks to your hint @clarencecromwell I recovered the image from the page's attachments, but now it is a jpg or png or whatever and I can no longer edit the diagram in DrawIO. Do you have experience with that?

I've found it, here is how to recover all of your hard work:

A seemingly lost DrawIO diagram is saved as 2 attachments to your page: one is a png file, the other is the DrawIO source document in xml format.

Save this xml to a local file, go back to your page in "edit" mode, insert a new DrawIO diagram and choose File > Import from > Device ...

Your original drawing fill load perfectly fine in the editor!

There may be other ways, but this is how I saved my day.

This link doesn't work. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

156 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you