Required plugin com.atlassian.plugins.atlassian-nav-links-plugin:rotp-menu was either missing or disabled

Hi,

after a fresh install i got the following error:

Error occurred during template rendering: Invocation of method 'getRenderedTemplateHtml' in class com.atlassian.confluence.plugins.soy.VelocityFriendlySoyTemplateRenderer threw exception com.google.common.collect.ComputationException: java.lang.IllegalStateException: Required plugin module com.atlassian.plugins.atlassian-nav-links-plugin:rotp-menu was either missing or disabled at /decorators/includes/common-header.vm[line 4, column 49]. Contact your administrator for assistance.

How can i solve this issue?

14 answers

1 accepted

0 votes
Accepted answer

@Andrey and OP: Confluence isn't tested or supported on Tomcat 7. Try with Tomcat 6 and contact Atlassian Support if the problem persists.

I used Atlassian Support and they gave me a link that fixed issue:

https://confluence.atlassian.com/display/CONFKB/Plugins+are+Disabled+at+Startup+and+Various+Timeout+Errors+Appear+in+the+Logs+After+Startup

My Server OS is Ubuntu Server 10.04 LTS.

Hi Ogger,

From the look of your error message, one of the plugin modules in your instance hasn't been enabled as expected so I'd like to ask you to follow the instructions in this Knowledge Base article as it should help you to resolve this problem: https://confluence.atlassian.com/display/CONFKB/Plugins+are+Disabled+at+Startup+and+Various+Timeout+Errors+Appear+in+the+Logs+After+Startup

All the best,
John

Hi John,

i have tested, but it wont work.

KR,

Ogger

Same issue. Fresh install from 64-bit installer.

Any advice? Posted link is broken for me (maintenance message). I'd like to try confluence but am blocked on this issue. Could it be java version related? I have jdk 1.7.0_15, fairly recent and the newest.

Same issue - any update on this? Java version? I've got jdk 1.7.0_15 - fairly new.

I keep getting the "Sorry Mate" page when trying to access this page over the last two days.

Hi Ogger,

May I ask you, if you have any kind of customization in your instance? I'm asking that because I noticed that this file is being affected /decorators/includes/common-header.vm. To see if that is the case, could you please check in Confluence Admin > Look and Feel and verify the following:

  • Themes: See which theme you're using, switch back to the default if you're not using it already.
  • Layouts: See if you have any custom layout defined, if yes then make a backup and reset to default.
  • Stylesheet: See if you have custom stylesheet, if yes then make a backup and reset to default.
  • Custom HTML: See if you have any custom HTML defined, if yes make a backup then reset to default.

Cheers,

WZ

I have this same error with Confluence 5.0 and if I try to go Admin Concole I get same error message. I am not made any customization in my instance.

Hi William,

i have not made any customizations to confluence. Its a clean install. After the Install process i get the message from my first post. The system is a ubuntu 12.04 virt. Machine on a VSphere hypervisor. What i am using? Tomcat7, openjdk 7 and ear/war distr.. I have switched to oracle java 7 without any solution. It want work.

KR,

Ogger

I'm seeing this on a fresh install - I haven't done anything other than run the 64bit linux installer.

I'm seeing the identical error, on fresh EAR/WAR installs of confluence 5.0-rc3 and confluence 5.0.1 (on OS X, with JDBC connect to MySQL); the install completes normally up to the "start using confluence" item, which generates the following html:

  • You have temporary access to administrative functions. Drop access if you no longer require it. For more information, refer to the documentation.

Error occurred during template rendering: Invocation of method 'getRenderedTemplateHtml' in class com.atlassian.confluence.plugins.soy.VelocityFriendlySoyTemplateRenderer threw exception com.google.common.collect.ComputationException: java.lang.IllegalStateException: Required plugin module com.atlassian.plugins.atlassian-nav-links-plugin:rotp-menu was either missing or disabled at /decorators/includes/common-header.vm[line 4, column 49]. Contact your administrator for assistance.

This error renders the entire install inaccessible (it's thrown from dashboard.action, admin/console.action, etc)

I've tryed all of this but can't resolve this problem。

Error occurred during template rendering: Invocation of method 'getRenderedTemplateHtml' in class com.atlassian.confluence.plugins.soy.VelocityFriendlySoyTemplateRenderer threw exception com.google.common.collect.ComputationException: java.lang.IllegalStateException: Required plugin module com.atlassian.plugins.atlassian-nav-links-plugin:rotp-menu was either missing or disabled at /decorators/includes/common-header.vm[line 4, column 49]. Contact your administrator for assistance.

I speak from personal experience. I've done all of the above without solving the problem.
Then I increased from 2 to 4 processors the virtual machine and everything worked properly.

Increasing the value of Datlassian.plugins.enable.wait seemed to work at first, but was not enough on my machine, even when I increased it to 600 seconds.

I ended up creating a scheduled task (the pc is running windows 7), which waits for 10 minutes after bootup and then calls a batch file that starts the confluence service. Contrived, but it works... most of the time. :p I never had this problem (been using confluence for a couple years) prior to this update.

Additionally, in case the

On fresh install process on linux, I had the same issue with Confluence 5.1.3. I extended timeout duration to 20 min. with setenv.sh. There is no luck after 20 min. just got the same error, "Error occurred during template rendering..." as explained above. need help

Same problem: Mac OS X 10.8, JDK 1.7, TomCat 7

I got this issue while upgrading from FECRU 3.1.4 to 3.3.1.

I believe the problem was that the content and templates for the old version were referencing taglibs from plugins not available in the latest version. Perhaps they were deprecated in-between.

Removing FISHEYE_INST/templates and FISHEYE_INST/content solved the issue

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

103 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you