Random embedded images missing from Confluence documents (after update?)

We've noticed that a handful of random images have gone missing from our Confluence documents. The image shows up with a broken link icon. When clicking the image, it takes you to a blank overlay with the following URL at the top:

 

http://server:8080/download/attachments/8618173/image2017-4-19%2014%3A33%3A11.png?version=1&modificationDate=1492630391352&api=v2

 

Is there a way to recover images?

1 answer

Check the file permissions on the Confluence home directory. It's probably easiest to just change ownership on the entire home directory structure to be owned by the user that Confluence runs as. If Confluence was running with a privileged user at some point in its life and now is running as an unprivileged user, you may see this sort of behavior.

If that isn't it, I'd recommend opening an Atlassian Support issue. Attachments don't just disappear during an upgrade normally, so something bad may have happened.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Confluence Cloud

Happy holidays from our team to yours!

Hi Community!  2018 was filled with changes for our team, both big and small, and we've taken a lot of time to both celebrate our wins and recognize areas of improvement. One thing that we're a...

104 views 1 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you