Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Problems with authentication

Hello,

 

we got some problems at our confluence setup. Its connected to a Crowd server but unfortunatly local users and remote users cannot be authenticated anymore to confluence, so i have lost completly access to confluence.

Does anyone have an idea how to gain access again?

 

2020-02-25 10:12:36,247 INFO [read-only-transaction:thread-1] [atlassian.confluence.user.DefaultUserAccessor] getUserNamesWithConfluenceAccess Could not find group configured with USE permission: confluence-users
2020-02-25 10:12:36,248 INFO [read-only-transaction:thread-1] [atlassian.confluence.user.DefaultUserAccessor] getUserNamesWithConfluenceAccess Could not find group configured with USE permission: confluence-administrators
2020-02-25 10:12:36,248 INFO [read-only-transaction:thread-1] [atlassian.confluence.user.DefaultUserAccessor] getUserNamesWithConfluenceAccess Found USE permission with no associated username or group: [USECONFLUENCE,0,null,null]
2020-02-25 10:12:38,384 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
[atlassian.seraph.auth.DefaultAuthenticator] login login : 'admin' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie

 

Actually getting this errors.

Password was already recovered for the admin user, and the length of the active field is also set to 1.

Does anyone have an idea how to fix it?

1 answer

Hi,

Are you trying to integrate crowd with confluence for the first time? If so, could you please review the document below and confirm the settings.

https://confluence.atlassian.com/crowd/integrating-crowd-with-atlassian-confluence-198573.html

If you really want local users to login in order to troubleshoot, you can edit seraph-config.xml file to switch to confluence default authenticator (ie

<authenticator class="com.atlassian.confluence.user.ConfluenceAuthenticator"/>

Restart the confluence and try login with local users.

 

Thanks

Shankar 

Hi,

no its was working for 3 years but stopped working a time ago.

The seraph-config.xml looking like this:

 

<!-- Default Confluence authenticator, which uses the configured user management for authentication. -->
<!-- <authenticator class="com.atlassian.confluence.user.ConfluenceAuthenticator"/> -->

<!-- Custom authenticators appear below. To enable one of them, comment out the default authenticator above and uncomment the one below. -->

<!-- Authenticator with support for Crowd single-sign on (SSO). -->
<authenticator class="com.atlassian.confluence.user.ConfluenceCrowdSSOAuthenticator"/>

 

Already tried to uncomment the <authenticator class="com.atlassian.confluence.user.ConfluenceAuthenticator"/> line and comment out the <authenticator class="com.atlassian.confluence.user.ConfluenceCrowdSSOAuthenticator"/> but without success. Same error message came.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,604 views 7 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you