Problem with tables and following headings

I am having a problem when I insert a table on a page. All of my Heading 1 styles after the table are appearing without an underline. All of the Heading 1 styles before the table are fine, they appear with an underline.

Has anyone else had this type of formatting difficulty?

6 answers

This widget could not be displayed.
Joe Clark Atlassian Team Jan 30, 2012

Sounds strange! What version of Confluence are you using? Also, do you have any custom or third-party plugins installed?

This widget could not be displayed.

I am using Confluence 4.1 and have the following plugins installed.

  • Ad-hoc workflows
  • Arsenale Invisible Ink
  • RB Storage - Confluence
  • RB Storage - Core
  • RB Storage - Servlet
  • RB Support - Confluence
  • RB Support - Core
  • System Web Panels
  • Wiki Markup Plugin

This widget could not be displayed.

Can you reproduce this problem within mutliple pages?

Are you able to send me the page source (e.g. via Confluence Source Editor?)

Yes, it occurs on several pages. How do I access the Confluence Source Editor?

First install the Confluence Source Editor Plugin via your Universal Plugin Manager (on Administrator pages). Then open the page, click edit and on the upper right a new icon occurs which looks like "<>". Just click it and you are in Confluence Source Editor.

() (SOP Document Management viewsource viewpagesrc.action pageId=1936271.txt)

can you use this? it won't allow me to upload .htm. the first heading with the issue is named "Process"

Are you able to send me a screenshot as well?

this is a version of the page where the "Process" heading appears correctly, i.e. same as the preceeding headings. Notice, there is no table in the section above Process.

In this version of the same page, the "Process" heading and all following headings do not contain the horizontal line as do all of the preceeding headings. Notice that there is now a table above the Process heading.

ok, and what about the source code of the page? can you provide a screenshot of the source code as well?

Here is a snippet containing the heading for "Process"

This widget could not be displayed.

as far as I can see, everything looks fine with the source code and I can't reproduce it properly. Seems to be a bug in the used plugin as it also produces a table with a style as in Confluence 3.x ...

One last idea: try to use a different browser ...

The problem exists in both Chrome and IE. Which plugin are you referring to that would affect the table styles? I thought the tables were standard Confluence functionality.

Thank you.

yes they are ...

Haven't I got it wrong, that you generate the table (which once appears and once does not)?

When there is no table, heading 1 text appears formatted correctly, with a margin to margin horizontal line.

When there is a table, any subsequent heading 1 text appears formatted incorrectly, without a margin to margin horizontal line. This is a problem because now all of the heading 1 text on the page doesn't have the same formatting.

I insert my tables using the insert table tool on the toolbar.

This widget could not be displayed.

that's really strange as I can't see any additional style information if you add the table ...

I'm sorry but have no ideas to fix the problem!

Thanks for trying! I'll leave this open in case any one else as any ideas.

This widget could not be displayed.

ok, so I got that wrong ...

what version of Confluence do you run?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

595 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you