Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,368
Community Members
 
Community Events
176
Community Groups

Problem with Excerpt macro inside Expand macro

Edited

In the new editor, we are using the excerpt macro to pull info onto a page in a different space.

It appears to work--I can nest the Excerpt macro in the Expand macro--but on the new page, it appears as "Error loading excerpt" and has a scroll bar.

The content does appear if you click the expand arrow, but we don't want the error to appear, or the scroll bar.

Anyone else run across this issue?

2 answers

I just discovered a workaround for this:

On the main page:
/excerpt (hidden: this can be anywhere on the page)

/expand

       /excerpt include (tied to the above excerpt inside the above expand if needed)

 

If excerpt needed on another page:

/expand

       /excerpt include (tied to the above excerpt inside the above expand if needed)

0 votes
Brant Schroeder Community Leader Apr 24, 2022

@Megan Stanage I want to make sure I have this correct.

You are adding an excerpt include into an expand macro and getting an error?  You should not be able to add the excerpt macro into an expand macro.  If you somehow did that is probably the issue.  

Not "excerpt include" but "excerpt" - we want to use the content in this expand macro on another page.

Brant Schroeder Community Leader Apr 25, 2022

@Megan Stanage I am still not following.  Can you share a screenshot.  

Like Megan Stanage likes this

The two above screenshots are an expand in an excerpt. Same thing happens if I switch the excerpt into the expand.

Brant Schroeder Community Leader Apr 26, 2022

@Megan Stanage Thanks for the screenshots.  You are on server by the looks of it.  My guess is that the content in the expansion is causing the issue.  Are you using an additional macro inside the expand?  Have you tested using just some basic content like text (This should work)?

We use the Cloud version but the old editor.

The image editor on the new editor is awful and we use lots of screenshots. :(

Using text works fine.

Brant Schroeder Community Leader Apr 26, 2022

Do you have an additional macro inside the expand?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events