Problem when Confluence generate URL to Jira Issues at Notifications-Tasks

Hi,

I'm using Confluence 4.3.2 and it works fine, great job. But, I have a 'bug'.

Confluence 4.3 has the feature of notification-task dialog in the top right. Notifications work well and can see the contents of these, but when I try to access them, I see that the URL that generates in the issues of Jira is the URL of Confluence, and not Jira itself so if I pulse I got a logical error from Confluence that the page not exist.

But in macros that referred Jira issues, Confluence generates the correct URL.

It's a bug of this version? Any solution?

Thanks in advance!

Dani

4 answers

1 accepted

Hey Daniel, this seems to be a bug only in Confluence 4.3.2. I've just reproduced and created the ticket:

https://jira.atlassian.com/browse/CONF-27604

Thanks for raising awareness on this, mate!

Theo

Thanks for your help mate!

Hi Daniel!

I believe this issue could be related to this bug: CONF-26782

The workaround for this case is changing the URL directly in the database, as explained on the link above.

Could you check if this applies to your case?

Cheers!

Hi Bruna,

I check the database and I don't see that URL contain the absolute path in table "AO_9412A1_AONOTIFICATION".
For example, contain URL like " /browse/ATN-90" without server base URL. So I have to update to put the server base URL?
I think that is not a solution... because I need to put a cron job that update my table every day no?

Thanks!

Hey Daniel,

I have tried reproducing this using Confluence 4.3.3. and JIRA 5.2.2 and it seems to work as it should. Can you please check the remote application links in your Confluence Admin > Application Links, click on Configure and check the Application Details?

Cheers,

Theo

I check the Application Details and I don't see anything strange... everything is correct. I check my database and also all is correct.

I use Confluence 4.3.2 and Jira v5.2.1

For me, it was a bug of Confluence version 4.3.2.

I upgrade to 4.3.5 and the URL was generated correctly but I don't know why the problem solved... and in release notes of 4.3.5 don't mention anything about the solvetion of this bug.... :(

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

1,898 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you