Problem in deploy database

Hello Nic Brough,

"mvn clean" and "mvn install -P developer,systemvm" success but when i try  "mvn -P developer -pl developer -Ddeploydb" that show below error. In this log  bold text is error text that I find in log. can you send me any solution for this on my email aksh1150@gmail.com?

 

 

$ mvn -P developer -pl developer -Ddeploydb
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Apache CloudStack Developer Mode 4.6.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- maven-checkstyle-plugin:2.11:check (cloudstack-checkstyle) @ cloud-de
veloper ---
[INFO] Starting audit...
Audit done.

[INFO]
[INFO] --- properties-maven-plugin:1.0-alpha-2:read-project-properties (default)
@ cloud-developer ---
[WARNING] Ignoring missing properties file: C:\cygwin\home\akshi_000\cloudstack\
developer\..\utils\conf\db.properties.override
[INFO]
[INFO] --- maven-remote-resources-plugin:1.3:process (default) @ cloud-developer
---
[INFO]
[INFO] --- maven-antrun-plugin:1.8:run (default) @ cloud-developer ---
[INFO] Executing tasks

main:
[INFO] Executed tasks
[INFO]
[INFO] >>> exec-maven-plugin:1.2.1:java (create-schema) > validate @ cloud-devel
oper >>>
[INFO]
[INFO] --- maven-checkstyle-plugin:2.11:check (cloudstack-checkstyle) @ cloud-de
veloper ---
[INFO] Starting audit...
Audit done.

[INFO]
[INFO] <<< exec-maven-plugin:1.2.1:java (create-schema) < validate @ cloud-devel
oper <<<
[INFO]
[INFO] --- exec-maven-plugin:1.2.1:java (create-schema) @ cloud-developer ---
log4j:WARN No appenders could be found for logger (org.springframework.core.env.
StandardEnvironment).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more in
fo.
========> WARNING: Provided file does not exist: C:\cygwin\home\akshi_000\clouds
tack\developer/../utils/conf/db.properties.override
========> WARNING: Provided file does not exist: C:\cygwin\home\akshi_000\clouds
tack\developer/developer-prefill.sql.override
========> Initializing database=cloud with host=localhost port=3306 username=clo
ud password=cloud
============> Running query: drop database if exists `cloud`
SQL exception in trying initDB: com.mysql.jdbc.exceptions.jdbc4.CommunicationsEx
ception: Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driv
er has not received any packets from the server.

1 answer

1 accepted

0 votes
Accepted answer

I don't know quite what this has to do with Confluence to be honest.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Feb 06, 2019 in Confluence

Try out the new editing experience

Hi team, I’m Avinoam, a product manager on Confluence Cloud, and today I’m really excited to let the Community know that all customers can now try out the new editing experience and see some of the ...

1,124 views 60 8
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you