PageTree not displaying in Documentation Theme

I'm using the Documentation Theme for the first time. I've configured the theme for the particular space to display the PageTree, but nothing shows up. I also tried adding some WML in the Navigation section of the Documentation Theme configuration screen, and again, nothing shows up.

The navigation panel is blank... I can control the width of the panel. I've looked through the logs and nothing is jumping out at me.

Any suggestions on things to try?

Dave

2 answers

1 accepted

This widget could not be displayed.

Check that all the plugin modules for the Documentation Theme are enabled. Specifically:

Turning on the Velocity Helper from the plugins administration screen

Wouldn't you know it... 9 of 10 modules were enabled. The one not enabled... Velocity Helper. You Nailed it Matt! Everything is working as expected.

Thanks!

Dave

David Simpson Community Champion Sep 21, 2011

This is a favourite answer to a number of plugin related problems -- go to the plugin and check that all the modules are enabled. Plugin modules occasionally have a habit of disabling themselves.

Note that for Confluence 4 plugins which are backward compatible with 3.x, the Confluence 4 specific modules will not be enabled for Confluence 3.x.

Yeah... sadly I went and looked at the PageTree plugin... not the Documentation Theme. DOH!

This widget could not be displayed.

Hallo David

The most likely cause is that the pages in your space are not children of the space’s home page

Each space has a single page designated as its “Home” page. The theme constructs the table of contents from all pages that are child pages of the space’s home page. If your pages are at the same level as (i.e. siblings of) the space home page, they will not appear in the left-hand navigation bar.

More background: The theme uses the {pagetree} macro to produce the table of contents on the left. When you use the {pagetree} macro on a page, you can choose the top page to be displayed. The Documentation Theme chooses the space home page as the top page.

The fix: If this is the cause, then there are two ways to fix the problem:

  • You can change the designated space home page for the space. You need space administrator permissions. Go to “Space Admin” and select “Edit Space Details”.
  • Or you can drag and drop all your pages to make them children of the current home page. Go to “Browse”, “Pages” and click the “Tree” option.

I hope this helps!

Cheers, Sarah

You can change the designated space home page for the space. You need space administrator permissions. Go to “Space Admin” and select “Edit Space Details”.

Fixed my issue.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Aug 14, 2018 in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

173 views 12 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you