Page is created when clicking "CLOSE" not "SAVE"

Confluence 5.9.6

When on the final editing screen when creating a new page from template or blueprint, clicking "Close" creates the page.

We believe it started when a custom plugin was installed, but not sure because we don't know what controls this behavior.

What the fruit could the plugin have possibly done to break the "Close" button?  For ALL templates?

Is this known and what is the cause?

EDIT: I confirmed that when in the editor screen for the first time on the new page, the URL does indicate a "draft ID", so that would suggest the engine hasn't created the page yet, right?  Who knows?  Upon clicking "Close", we land on the newly created page, it shows up in the space and is searchable, so it definitely was created from the draft.

 

EDIT 2016-05-02: Contacted support, they said "it is unfortunately beyond our support scope."  Should I open a bug, or is there really a way for a plugin to break the editor's "close" link across the whole site?  If there is a known way to do this, isn't this something support could have told me about?  So, I'm guessing there is not supposed to be a way to do this, so this is a bug.  Right?  So if it's a bug, why wouldn't support help us?

 

5 answers

This widget could not be displayed.

I've checked here, Tadd, and doesn't seem like it's a known issue. Best to contact support, I'd say, so they can work through it with you. If you don't get a better answer from the community, that is.

This widget could not be displayed.

Thank you. We are contacting support now.  Maybe something nefarious in the plugin is changing the behavior here, so I'm hoping that it's just a plugin configuration tweak or something. However, that is terribly insecure if that is the case. What's going on (consider me completely naive about Confluence internals) I think is less what the "close" button does and more about whether the page is actually created before the editor is opened, or after.  This behavior might be desired to be changed by some, FOR THEIR PLUGIN.  However I recently showed that when in the editor for the first time on new page creation, the URL does show a draft ID, suggesting the page hasn't been created yet, and clicking "Close" actually triggers the creations...ack.

This widget could not be displayed.

Just an update, no help from support.

This widget could not be displayed.

This might be a tricky one, so it may take support a while to track down the right answer. Hopefully they'll contact you soon, even if it's just to say that they're looking into it.

This widget could not be displayed.

Dude, they DID contact us already, and said "it's beyond the support scope".  This means that they are not going to help at all, they didn't say "we'll get back to you". I wrote that in an EDIT to the post.

They are NOT going to look into it, they told us to pay someone to fix it. 

Did you get anywhere with this?  Got an old install that's also experiencing this issue.

Losing all sorts of page content on saves as well.

Should get an upgrade window soon to latest 6.x

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

477 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you