Page Information Macro not working after updateting Confluence to 5.2.3

On page we get This page contains macros or features from a plugin which requires a valid license.

Also we have Plugin Licensing Manager and license for this plugin installed. But it seem that this license somehow got disconnected from the plugin:

This is the Adaptavist Essentials Plugin Pack.

There are no enabled plugins that require this license.

I tried to re-issue license and upload it to plugin manager, but that didn't help

When opening page we have logged this:

2013-08-21 15:37:55,367 ERROR [http-8090-11] [plugin.licensing.internal.PluginLicenseServiceImpl] getPluginLicensing No plugin found with key: com.adaptavist.confluence.pageinfo

-- url: /pages/viewpage.action | page: 2293867 | userName: mvm65 | referer: http://conf.kant.komus.net/pages/viewpage.action?pageId=1081361 | action: viewpage

2013-08-21 15:37:55,367 WARN [http-8090-11] [plugin.licensing.internal.PluginLicenseServiceImpl] isLicensed Plugin com.adaptavist.confluence.pageinfo has no license

-- url: /pages/viewpage.action | page: 2293867 | userName: mvm65 | referer: http://conf.kant.komus.net/pages/viewpage.action?pageId=1081361 | action: viewpage

5 answers

1 accepted

Adaptavist support has sent me plm-plugin-0.7.0-beta5 that solved the problem

0 vote

Hello Vladimir,

This sounds like some cache issue with the plugin. have you tried to remove and install the latest version of the Adaptavist Essentials Plugin Pack? can you confirm that this plugin is compatible with the latest version of confluence?


If the issue persists, I suggets to get in touch with adaptavist so they can help you better with this issue. :)

Regards,

Rodrigo

I don't have Adaptavist Essentials Plugin Pack installed as a single plugin. In fact, couldn't find this pack as a single plugin on Marketplace and on http://www.adaptavist.com/w/Plugins/

I have separate plugins called Adaptavist Content Formatting Macros and Page Information Tools both version 3.0.0.

I tried to disable and to remove Page Information Tools plugin but no use

Now I noticed that Page Information Tools has only 6 of 16 modules switched on. Modules called Pack License and Plugin License are off/

Maybe that is why license shows up as invalid. Logs of enabling the plugin attached

(logs.log)

Adaptavist updated Plugin Licensing Manager to be compatible with Confluence 5.2.3 and Page Information Macro now works OK.

I have the same issue. Just upgraded Confluence 5.4. Plugins will no longer work. It says I need a valid licence. However the licence is good but a bunch of the modules within the plugin are disabled.

Same problem here. I just upgraded to Confluence 5.4 and have the exact same problem

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

344 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you