One Administrator Can Not Access Administrator Functions After Switching to HTTPS

We are using JIRA v7.1.7, Confluence v5.10.0 (with Team Calendar), and Bitbucket.  Recently, we were required to change to https from http, which we did via port 8443 for JIRA and 8444 for Confluence.  We have two accounts with Administrator priviledges, mine and the task lead's account.  I've checked, and we are both in the same groups.  We have no problems with JIRA, but with Confluence, the task lead can not access Administrator areas.  I've tried everything I can think of to fix this problem...and am concerned that tomorrow my account may have the same issue as his.

Here is the error message he gets: 

Oops - an error has occurred  System Error A system error has occurred — our apologies! For immediate troubleshooting, consult our knowledge base for a solution. If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:

  1. a description of your problem and what you were doing at the time it occurred
  2. a copy of the error and system information found below
  3. a copy of the application logs (if possible).

Your Confluence administrator can use the support request form to create a support ticket which will include this information. We will respond as promptly as possible. Thank you!

--------------------------------------------------------------------------------------

We can not request support from Atlassian because we are a small team with just the starter license.

Here is our server.xml file:

<Server port="8000" shutdown="SHUTDOWN" debug="0">
    <Service name="Tomcat-Standalone">
        <Connector port="8090" connectionTimeout="20000" redirectPort="8444"
                maxThreads="48" minSpareThreads="10"
                enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
                protocol="org.apache.coyote.http11.Http11NioProtocol" />

        <Engine name="Standalone" defaultHost="localhost" debug="0">

            <Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false">

                <Context path="/confluence" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
                    <!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
                    <Manager pathname="" />
                    <Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
                </Context>
            </Host>

        </Engine>

        <!--
            To run Confluence via HTTPS:
             * Uncomment the Connector below
             * Execute:
                 %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA (Windows)
                 $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA  (Unix)
               with a password value of "changeit" for both the certificate and the keystore itself.
             * Restart and visit https://localhost:8443/

             For more info, see https://confluence.atlassian.com/display/DOC/Running+Confluence+Over+SSL+or+HTTPS
        -->

        <Connector port="8444" maxHttpHeaderSize="8192"
                   maxThreads="150" minSpareThreads="25"
                   protocol="org.apache.coyote.http11.Http11NioProtocol"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" scheme="https" secure="true"
                   clientAuth="false" sslProtocols="TLSv1,TLSv1.1,TLSv1.2" sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2" SSLEnabled="true"
                   URIEncoding="UTF-8" keystorePass="<MY_CERTIFICATE_PASSWORD>"/>

    </Service>
</Server>

--------------------------------------------------------------------------------------

THANK YOU for any help you can provide!!

Anna

1 answer

0 votes

Start with a look at the log file at the time that this error occurs, and tell us exactly what he does to provoke it (e.g. when he clicks the admin cog, or when he tries to enter his password to check he's an admin, or on an admin action etc)

What is the name and path of this log file?

Usually atlassian-confluence.log in the log directory of confluence's "home" directory.

To save some digging around, go to admin-> system information, it should explicitly name it with the whole path in there.

I am in the process of getting the task lead to repeat the action so that I can pinpoint exactly which error lines in the logfile are caused by him failing to log in as administrator.  I'll post the information you requested as soon as I can.  Thank you!!

OK, there are a bunch of errors in the log file that occur when Confluence is coming up and he is logging in as a regular person...but nothing when he gets the error message I described when he tries to log in as an Administrator.  Surely, the prior error messages indicate what caused the problem.  I would like to note that JIRA has connections to Git and BitBucket that are on another server that is not yet secure.  My next posting will be of the error log messages.  My employer requires that I sanitise the files first (i.e., remove IP addresses and hostnames).  Thank you!!

OK, interesting:  the error messages were eventually added to the file.  Maybe sometimes it waits for a memory flush before writing to the log file?  Anyway, here it is, with the URL and server name sanitised out, there were no ip addresses in the file.  Thanks for any advice you have in advance!!


UPDATE:  I tried to post and Atlassian said it contained either foul language or spam...which it did not...it was just something copied from their log file. :)  I will try to paste just the error message that I see most frequently when I go back through the log (which was quite interesting, BTW...thanks for that.)

com.atlassian.crowd.exception.InvalidCrowdServiceException: The following URL does not specify a valid Crowd User Management REST service: http://jira.serv:8080/rest/usermanagement/1/search?entity-type=user&start-index=0&max-results=-1&expand=user
 at com.atlassian.crowd.integration.rest.service.RestExecutor$MethodExecutor.executeCrowdServiceMethod(RestExecutor.java:604)
 at com.atlassian.crowd.integration.rest.service.RestExecutor$MethodExecutor.andReceive(RestExecutor.java:481)
 at com.atlassian.crowd.integration.rest.service.RestCrowdClient.searchUsers(RestCrowdClient.java:557)
 at com.atlassian.crowd.directory.RemoteCrowdDirectory.searchUsers(RemoteCrowdDirectory.java:371)
 at com.atlassian.crowd.directory.ldap.cache.RemoteDirectoryCacheRefresher.findAllRemoteUsers(RemoteDirectoryCacheRefresher.java:55)
 at com.atlassian.crowd.directory.ldap.cache.RemoteDirectoryCacheRefresher.synchroniseAllUsers(RemoteDirectoryCacheRefresher.java:90)
 at com.atlassian.crowd.directory.ldap.cache.AbstractCacheRefresher.synchroniseAll(AbstractCacheRefresher.java:89)
 at com.atlassian.crowd.directory.ldap.cache.EventTokenChangedCacheRefresher.synchroniseAll(EventTokenChangedCacheRefresher.java:67)
 at com.atlassian.crowd.directory.DbCachingRemoteDirectory.synchroniseCache(DbCachingRemoteDirectory.java:1122)
 at com.atlassian.crowd.manager.directory.DirectorySynchroniserImpl.synchronise(DirectorySynchroniserImpl.java:76)
 at com.atlassian.crowd.directory.DbCachingDirectoryPoller.pollChanges(DbCachingDirectoryPoller.java:50)
 at com.atlassian.crowd.manager.directory.monitor.poller.DirectoryPollerJobRunner.runJob(DirectoryPollerJobRunner.java:93)
 at com.atlassian.confluence.impl.schedule.caesium.JobRunnerWrapper.doRunJob(JobRunnerWrapper.java:129)
 at com.atlassian.confluence.impl.schedule.caesium.JobRunnerWrapper.lambda$runJob$0(JobRunnerWrapper.java:89)
 at com.atlassian.confluence.impl.vcache.VCacheRequestContextManager.doInRequestContext(VCacheRequestContextManager.java:82)
 at com.atlassian.confluence.impl.vcache.VCacheRequestContextManager.doInRequestContext(VCacheRequestContextManager.java:72)
 at com.atlassian.confluence.impl.schedule.caesium.JobRunnerWrapper.runJob(JobRunnerWrapper.java:89)
 at com.atlassian.scheduler.core.JobLauncher.runJob(JobLauncher.java:153)
 at com.atlassian.scheduler.core.JobLauncher.launchAndBuildResponse(JobLauncher.java:118)
 at com.atlassian.scheduler.core.JobLauncher.launch(JobLauncher.java:97)
 at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.launchJob(CaesiumSchedulerService.java:401)
 at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJob(CaesiumSchedulerService.java:396)
 at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeQueuedJob(CaesiumSchedulerService.java:349)
 at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:255)
 at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:252)
 at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeJob(SchedulerQueueWorker.java:65)
 at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeNextJob(SchedulerQueueWorker.java:59)
 at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.run(SchedulerQueueWorker.java:34)
 at java.lang.Thread.run(Unknown Source)

ok, that means Crowd is not available on the url in the first line.  I don't know if it's the internal crowd or external one you are using?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in New to Confluence

How to use Confluence Cloud for stakeholder management

Most of us don’t need much convincing that stakeholder management is important. It just makes sense that keeping everyone in-the-know on projects and assigning clearly defined roles is key to having ...

1,073 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you