Odd characters on macros

Hi there, I have a Confluence 4.3.7 installation which works well. When I edit pages, alas I see this instead of the normal macro code:

2014-11-17 11.36.03 am.png

Does anyone have any ideas as to what happened here? And, more critically, how I can change it? I have tried accessing the site using Firefox 33.1 as well as Safari 7.1.

 

Thanks,
Niels

6 answers

This widget could not be displayed.

Hi Niels,

that's a interesting behavior. I believe we might be facing a encoding issue with confluence database. Was there any change to the DB lately?

Can you run the encoding test located in this page and check if the issue happens?

If the issue happens, then I recommend to follow the step 2 of that doc to correct the encoding.

Cheers,

Rodrigo

This widget could not be displayed.

Can you confirm if this is happening with all the macros or is it only with specific ones?

Also, will this happen with different pages?

 

Regards, 

GIuliano

This widget could not be displayed.

Rodrigo: Thanks! Let me try that. I am on the road at the moment so I will need a day or two...

GIuliano: It happens on all pages (well, all pages that I looked at) and with all macros (well, all macros I have seen -  including when I add a macro. So typing "{info" will lead to immediate gobbledegook...

This widget could not be displayed.

Hello Niels,

we are also experiencing issues like that (see Strange character added to macro body) and couldn't find the problem. So I'm very interested if you can find a solution. smile

There also seem to be others suffering from this: Strange à character in Confluence Editor - no URL rewriting. This thread could be interesting for you, too, @Benjamin Ingersoll.

Cheers,
Kirstin

Thanks for the mention, @Kirstin Seidel-Gebert!

This widget could not be displayed.

I will let you know @Kirstin Seidel-Gebert...

This widget could not be displayed.

Well, it seems the problem is local. After trying to correct the character coding (and crashing the site in the process – thanks to backups!!!!), I see that I can see all using Chrome. Whereas on FF and Safari I see the garbled macros as shown above.

Don't ask me why...

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

567 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you