Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Not Able to Install An App On My Instance of Confluence Edited

 I want to install https://marketplace.atlassian.com/apps/41025/plantuml-for-confluence?hosting=server&tab=overview but am getting errors. These screenshots can show what I am seeing...

 

First, I was not able to locate the app through the "Find New Apps" in settings (it does not come up even with several searches...

 

Screenshot 2021-06-17 at 00-47-14 Find new apps - Confluence.pngScreenshot 2021-06-17 at 00-50-33 Find new apps - Confluence.png

 

Then I found these instructions to upload from a file (I am able to download the file through the app page linked at the top of this post. The documentation in the https://confluence.atlassian.com/upm/installing-marketplace-apps-273875715.html section shows the dialog window having an "Choose File" feature but I do not have that in mine.

 

Here is what my dialog window looks like (no option to choose a file)...

 

Screenshot 2021-06-17 at 11-27-28 Manage apps - Confluence.png

 

You can see all the urls I tried and the error I'm getting. I don't know why I'm getting that or why I can't get this app...

 

Screenshot 2021-06-17 at 11-27-43 Manage apps - Confluence.png

 

What am I doing wrong? Why can't I install this app? An, ultimately, what can I do to get this app installed?

 

Ps: I did see https://community.atlassian.com/t5/Answers-Developer-Questions/cannot-be-installed-on-this-Cloud-instance/qaq-p/570117 but it is really not the same. Its teh same error message but that person seems to be making an app. I'm trying to install one that is already made and (seems to be) on the marketplace as a fee app.

 

 

Thanks

1 answer

1 accepted

I'm using Confluence not Jira.

Then what does "Free app" mean?

 

Screenshot 2021-06-17 at 11-37-42 PlantUML for Confluence.png

Hi @Jake - The URL that you tried is for Confluence Server and the one I shared is for Confluence Cloud

@Jake  - Server compatible version of the plugin is free of cost. 

The Cloud version seems to be a commercial one.

https://marketplace.atlassian.com/apps/1215115/plantuml-diagrams-for-confluence?hosting=cloud&tab=overview

 

^ That does not even look like the same app. It is by Stratus Add-onsbut the one I was trying to install is by avono AG

 

(two different developers). I can see that there are many different apps for plantUML but I was wanting the one I am asking about in the original post. Is that possible?

deleted by poster

@Jake - The PlantUML for Confluence app by avono AG is Cloud incompatible

Like Jake likes this

I see. Thanks for getting me squared away about that.

No worries. Kindly accept the answer so that the post will be marked as SOLVED. Thanks and Good luck

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS
Community showcase
Published in Confluence

🏑 Atlympic Event: Confluence

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

122 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you