No "Linked Jira Issues" Button in Confluence?!?

In Confluence next to the page title there used to be a button showing the count of linked JIRA issues you could click on to see them. It seems that this button has appeared and disappeared on my system.

My application links are working fine otherwise. Any ideas what would prevent Confluence from showing the linked issues?

Without this button, there is now way to see linked JIRA issues unless the macro is still part of the page. Any ideas?

Maybe somewhat related: I've been unable to determine whether I should be using oauth or trusted application for linking. 

4 answers

1 accepted

I was using the Documentation Theme which does not support the button. Problem solved. Silly me.

1 vote

Hi Seb, 

Can you confirm if you are facing this bug?

https://jira.atlassian.com/browse/CONF-32523

This was fixed on Confluence version 5.5.

 

Hope this helps.

 

Regards, 

Renato Rudnicki

 

1 vote

Hi Seb,


Just sharing the finding from our support ticket. The  documentation theme does not support the JIRA links feature as mentioned in the   https://confluence.atlassian.com/display/DOC/Using+the+Documentation+Theme and here https://confluence.atlassian.com/display/CONFKB/JIRA+Links+Button+Missing.

Therefore we will need to avoid the documentation theme if we want to use the JIRA links feature.


Hopefully this information helps!

Regards,
Jing Hwa

Hi Renato,

thanks for replying. I had looked at that bug report before and it seems to be exactly what's happening to me. But I'm on Confluence 5.7.4 and JIRA 6.4.2 so I thought it's me doing something wrong on my end. Now I'm not so sure.

I've reset the application links using OAuth and the linking works except for this one feature.

I've made a screenshot to show that the links themselves work but the button doesn't show:

Screen Shot 2015-05-16 at 09.52.33.png

That's the top right corner of a Confluence page. You can see the links are set up and working but the button still doesn't show.

Any ideas?

edit: we have the same problem in our C 5.5.4 J 6.3.9 environment.

There is no entry in the confluence log except when I open the link to Jira via the Macro that displays an issue: 2015-05-18 14:36:19,389 INFO [http-bio-8090-exec-3] [confluence.rpc.auth.TokenAuthenticationInvocationHandler] invokeAuthenticatedMethod Executing remote API method [ getPage ] as user [ myuser ]

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

982 views 23 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you