New installation can't edit

Hi there,

I have a brand new Confluence 6.6.1 installation. In order to secure it I've put an HAProxy in front of it.

All seems well until I try to edit any page or add a page.

I receive a red exclamation mark saying: This page is taking longer ...

I have researched the issue ad nauseum and disabled Collaborative editing.

Now I don't get any more errors in any logs, however, editing is still impossible - I get a spinning wheel so to speak.

Any help would be greatly appreciated - a wiki without editing is not a wiki.

- Cheers, Peter

1 answer

0 vote
Ann Worley Atlassian Team Jan 19, 2018

Hi Peter,

I understand you just installed Confluence 6.6.1 and have not been able to edit since you added an HAProxy reverse proxy, where SSL is terminated. Even with Collaborative editing set to Off you cannot edit pages.

Please let me know, can you edit if you bypass or disable the proxy?

We do not have explicit setup instructions for using HAProxy with Confluence, but I am hoping you can use the high level information (and diagrams) on this page to understand how Synchrony works, and configure your proxy to accommodate it: With a reverse proxy

If you post a redacted HAProxy configuration on this thread, someone who has set up HAProxy with Confluence 6.x may be able to help. I will be happy to research it further, as well.

Thanks,

Ann

Hi Ann,

thanks for your feedback. I'll test without HAProxy and will get back to you.

If it works, I'll post the HAProxy config.

- Cheers, Peter

Dear Ann,

I am now connected directly to the confluence server on ports 8090 and 8091.

I am experiencing the same problem. It seems to have nothing to do with the proxy after all.

Any suggestions on how to proceed?

It may have something to do with my LDAP connection.

I have configured LDAP Read Only.

Many thanks for your help, Peter

I just ran through the whole setup routine again - without LDAP this time.

I'm connected as a normal user / one I just created in the admin portal.

Even in this stage, I can only create a space and create a page.

However, as soon as I am trying to edit this page, I end up with this error:Screen Shot 2018-01-22 at 12.21.02.png

My OS is: CentOS 7, SELinux is in permissive

Database is PostgreSQL 10.1 on localhost

Any help would be greatly appreciated!

- Cheers, Peter

Just did another reinstall - with PostgreSQL 9.6 - just to be sure.

Still the same problem.

Editing of any page is not possible.

Thx, Peter

Ann Worley Atlassian Team Jan 22, 2018

Hi Peter,

The error you are seeing is associated with Collaborative editing: Confluence throws The editor didn't load this time error when trying to edit a page

Is this the same error you had in the beginning? I understood you couldn't edit with Collaborative editing off in the original description. Do you see the same message if Collaborative Editing is set to Off? I think you know how to turn it off but for the sake of posterity, here are the instructions: Change the editing mode

Thanks,

Ann

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Friday in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

274 views 11 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you