Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

My service desk customers cannot access knowledge base

Setup:

  • Jira (software and service desk) Server installation
  • Confluence server installation
  • Established application link in both directions
  • No "user sharing" from jira to confluence

Steps:

  1. Created service desk project
  2. Matching knowledge base space in confluence was created from service desk
  3. Created some articles in KB space
  4. Set knowledge base access in service desk project to "all active ..."
  5. Invited customer

Problem:

When I log in as agent I can search (from service desk) and find the KB articles and can open them in a popup in jira service desk (and copy the link).

When I log in as a customer I can create tickets as expected in the service desk project. But when I search for KB articles none are found. If I access the copied link I get an article not found message.

Documentation states that the customer should be able to search and display the KB articles in this szenario.

I asked it in the community and got the answer to activate anonymous access. My answer and disagreement to this is :

I don't think so. If you have to enable anonymous access to the knowledge base then why is there at the top of the permissions a special entry "All active users ... this was activated by service desk ..." (translated by me from german). It doesn't make any sense that jira service desk activates some super special kind of permission if you have to allow anonymous access anyway.

Also in service desk under knowledge base it is stated that all customers have access, even without confluence license. If it were needed to enable anonymous access to achieve this, service desk would have done it when creating the KB space inconfluence.

And by the way, if showing the knowledge base article is done in a popup in jira, why is access of the user to cinfluence even needed? Jira can (and seemingly does) pull the content via the application link and show it without ever handing the user over to confluence.

10 answers

please help this also happened to me 

Here ist what I could find out so far.

Given this:

  • Jira <-> Confluence Applink with OAuth with Impersonation
  • JSD Configured properly
    • KB registerd
    • All active custoemrs ... can access KB withoug CF license is on
  • Confluence entries KB created
  • Confluence Anonymous Use is off
  • Confluence Anonymous View is off

You need to do the following to allow the Customers to access the KB articles

  • Create a Jira User Server entry for Confluence
  • Add Jira Crowd as a User Directory and point it to the JSD
    • Move the new Jira Crowd connector to the very bottom to ensure it does not clash internal and/or AD users
    • Take special case about duplicate "admin" user accounts !

From now on searching something in the Customer Portal as a Customer works.

But I am also having the problem of not being able to click on the link pointing to confluence, like Jianhui Ho posted at Jun 11, 2019

But that is a different story.

Cheers,
Holger

I had JSD 4.3.1 linked to Confluence 6.15.4 and it didn't work. Then I updated to Confluence 6.15.7 and now it works.

Upgrading from Confluence from 6.15.4 to 6.15.7 resolved the issue for me as well. THANK YOU  G.M. K

 

The only difference for me was that I'm on JSD 4.2.4

0 votes
Danyal Iqbal Community Leader Aug 15, 2018

Sorry, but your questions are irrelevant. The scenario above works as stated in the documentaion. Please go through the documentation and your permissions again.

"Allow anonymous access" is meant for a different use case. It is only a workaround for your use case. However your use case is already covered in the documentation. https://confluence.atlassian.com/servicedeskcloud/serving-customers-with-a-knowledge-base-732528995.html

I did exactly that. I even created the KB Article from jira service desk. As you can see in the screen shots it should work:

Service Desk Kowledge Base Configuration:

SDKBSettings.jpg

And here the permissions of the KB space in confluence:

CFSpacePermissions.jpg

Now if we enter the customer portal as AGENT and search for "testbug" we find the KB article:

AgentAccess.jpg

Doing the same as a customer (with no Jira or Confluence license) we don't find the KB article:

CustomerAccess.jpg

Danyal Iqbal Community Leader Aug 16, 2018

Hi, Your permission model looks ok. I was expecting a screenshot of the Global Permission page as well:) Can you check if Unlicensed Access is allowed in confluence?(since customers dont have any license).

Looks good to me:

ConfluenceGlobalPermissions.png

I know this is old but I have the same problem. Did this ever get resolved? If so, please share the answer.

Thanks

Same here, it was working fine and then has now stopped, my settings are as above. We recently enabled the domain admin so we could add custom domains to send emails from. Could this have changed the settings in confluence? 

@Peter Kaiser 

We are facing the same issue. Please could you guide me if you were able to resolve this issue. 

Thanks!

Same error for me. Please help.

Receiving the same here also. A fix would be great

Also having the same issues with new users of the service desk. Did this get resolved?

I believe I am having the same issues. Any fix or way to diagnose?

It works for licensed users, but not for 'service desk customers'. 

Using a direct /display link works. So I'm guessing something is wrong with how jira searches for the url. 

image.png

I am having the same issue

I observed that using a direct link from Confluence is ok. Opening the article via service desk is not ok. 

Do any staff respond or watch this thread or should I start a new one? Haven't seen any replies.

Has anyone made progress regarding the issue outlined above?  I am experiencing the same issue.  All permissions appear to be set as outlined in the Atlassian documentation however no suggested knowledge base article content appears when searching as a 'jira-service-desk-user'.

same for me

Any update on this?

We have the KB space and content in confluence open to anonymous users but JSD needs sign in. My problem is that the links in the KB article shown (successfully) in JSD, links to other KB's, are not being shown. I get a Not found message.

Not sure what the issue is here and additionally not sure if this has been a problem for long or not.

Anybody have the same issue?

HildurScreenshot 2019-07-18 at 08.53.05.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

415 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you