Mail form macro breaks comments?

We've just run across a problem I haven't seen before. When you have a page with a mail form, you can't save comments – the Save button (for a new comment) appears to be enabled, but nothing happens when you click it or Cancel.  (Preview does work.) 

I don't see any JavaScript errors.

When I look at the page source, it looks to me like the </form> tag for the mail form is missing or misplaced.

It seems like this was introduced recently – we've got a comment from June 23 on a page with a mail form.

We're on Confluence 5.5 and Mail Form NG 4.0.3.  (I think we were still on 5.1 June 23, so it looks like the upgrade might be causing this.)

Anyone else see this?

4 answers

1 accepted

Hi Jonathan,

Hope this finds you well. 
In the  Form Mail plugin version 4.0.3 , this bug was reported and logged in our system.

  • FORMMAILNG-172 - Comments are not being saved on pages where Mail form macro is added

We have since then fixed this issue with the next release version 4.0.5 of the plugin. 
Please find below the version history as well as the release notes for the newly released versions.
https://marketplace.atlassian.com/plugins/com.adaptavist.confluence.formMailNG/versions

We would kindly ask you to upgrade to the latest version of our plugin v.4.1 which provides compatibility for Confluence version 5.4 - 5.7 as it now includes latest bug fixes and additional new features that have been included with this release.
Please find the documentation below to  acquaint yourself with all the new features and changes we have made with our FormMail plugin.
http://www.adaptavist.com/doco/display/FMCP/Form+Mail+for+Confluence+Plugin 

If you have any further queries, please do not hesitate to contact us via our Contact Us Form or write us an email at  plugin-support@adaptavist.com. Please be sure to set enquiry type to “Support services & Plugins”. Please provide the following information:

  • the version of Confluence  you are using,
  • the add-on name and version you are using,
  • all information regarding the issue you are facing including log files, steps to reproduce, screenshots, storage format etc.
  • the web browser used and its version number. "

 

-- 

Best Regards,
Supraja Thota  | QA Analyst | Adaptavist.com Ltd.
1st Floor, 35 - 39 Old Street, London, EC1V 9HX
Registered in England and Wales #5456785 | VAT Reg. GB 872 1217 39

 

Yes. The new version fixes the problem. Thanks!

Hi Jonathan,

I would contact Adaptavist which is the plugin vendor. They do have their own support line:
http://www.adaptavist.com/w/about/contact-us/

Cheers!
WZ

Hi Jonathan,

 

Apologies for the delay in getting back to you. We've now fixed this bug in the latest release - Form Mail 4.1. We've also added a series of new and improved features, making Form Mail more robust whilst giving you more options when creating and sending mail forms. Check out the latest release on the marketplace for more details.

 

Kind Regards,

Hessom

Adaptavist Product Team

This has been confirmed by Adaptavist as a bug

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

344 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you