It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Macros in global templates have no title bar information

Since my upgrade to 6.15.3 in the global templates, none of the macros have information in their title bars. What I see is the macros without any information attached to them.

2 answers

If you have Syncrony (collaborative editing) turned off, while running your instance on HTTPS, you might be affected by CONFSERVER-58220 (Having Collaborative Editing disabled and HTTPS will cause macros' titles to not show up).

Hello Azwandi! Nice to see you. :)

Thank you so much for sharing that with us.

@Think Technologies Group, this is another possibility for the cause of your issue. Let us know once you've had a look if you're able to determine which one affects you, and let us know if you have any trouble.

Regards,

Shannon

Like azwandi likes this

Hi All, 

 

I was super excited and then looked and found collab and syncrhony to be enabled. Would it make sense to turn it off and on again?

0 votes

Hello,

Thank you for reporting this to us. Would you be able to send me an example in a screenshot of what you're referring to? I'd like to look into this and see if it's a bug, or expected behavior.

Regards,

Shannon

2019-07-22_1557.png

 

Hi! Sorry for the slow response. I didn't get an email that this was answered. See above. If I add a new macro, the name appears int he title bar of the macro, but for all existing, they are blank.

Hello,

Thank you for clarifying this with a screenshot. I'm not able to replicate this on my own instance.

  1. Does it only occur with specific macros? If you were to remove any 3rd party macros from the page, does the issue persist? (e.g. does this only occur if you use the ServiceRocket macro?)
  2. Do you have any customizations in your Confluence instance? If so, would you be able to clear those so we can ensure it's not causing this issue? (See How to Clear Customizations from Confluence.)

Thank you for your help!

Regards,

Shannon

Hi Shannon,

 

It occurs with all macros I have on a page when i first go to edit the template. If I edit a macro, the the title will show up. I went through the customizations page you sent me (thanks) but unfortunately it did not help. :(

Thank you for verifying.

I have a few more suggestions and questions.

  1. Can you confirm if this happens on both Space and Global templates?
  2. Are you using a proxy or firewall to access your Confluence instance? If so, could you please try to bypass that and see if you have the same issue?
  3. Enable Safe Mode and let us know if you still have the same issue.
  4. Clear your plugins cache. This will require a Confluence restart so you may need to schedule this during maintenance hours.

Take care!

Regards,

Shannon

Hi Shannon,

 

I dont have any space templates, just global. It happens no matter which site I access Confluence from either outside of our datacenter or inside of it. I have actually done 3 & 4 previously and that did not resolve it either.

Hello there,

This can sometimes be caused by an add-on, such as Scroll Versions. Do you have anything like that installed at the moment?

Regards,

Shannon

Hi Shannon,

 

I have tons of add-ons, but aren't they automatically disabled in safe mode? Here's a list:

 

ServiceRocket Scaffolding

Service Rocket Reporting

SpaceTreeCreator

Gliffy Diagrams for confluence

Table Filer and Charts for Confluence

GoEdit Client Editions

GoEdit for Confluence

Linking for Confluence

Reporting COnnector for SQL Databases

ServiceRocket Utility Library

 

I just did it again to be safe and a standard macro called "Section" shows up without the title bar filled out.

@Think Technologies Group,

Yes, it should disable all add-ons, but occasionally you might need to check to make sure they were properly disabled.

I'm still not able to replicate this; it's a very odd case. 

I reviewed your notes and I see that you have only ever referred to this problem within the global templates.

Does this mean, if you check existing pages that you have created, the macros all show titles? It's only on your template pages?

Are you able to replicate this with a staging instance of Confluence? 

Could you show me an example of a page that has this problem which contains no 3rd party macros or customizations?

Regards,

Shannon

Hi Shannon,

I double checked and all plugins were disabled in safe mode. As for macros on regular pages, I haven't found any issues, just in the global templates. I just tested a space template and it definitely does it there as well!

 

Test space template after putting a section macro and hitting save and then going back to edit the template:

Space-Template-SectionMacro.png

Test space template after putting a section macro and hitting save and then going back to edit the template and then hitting edit on the macro and save again (this makes the title for that single macro show up)

Space-Template-SectionMacro-After-ReEditing-SectionMacro.png

Hello,

Thank you for sharing that information. I'm still not able to replicate this myself, but I believe it's possible you could be running into this bug: 

  • CONFSERVER-57934 Adding panel,excerpt,warning,note,tip or info macro to the page in edit mode will trigger mixed content action in browser

In this case, the problem is only with certain macros. I'd like to test if this is what is affecting you.

  1. The behavior will change across various browsers, but the main issue is that http is being used in requests when it should be https.
  2. To test this, I recommend recording a HAR file of the page load, and then have a look at your HAR file to see if you see any http requests.

Could you give that a try and let me know what you find out?

Regards,

Shannon

Hi Shannon,

I started the har recording and found that there were a bunch of errors with something reaching out to the HTTP part of the page. I'm not sure what to do to resolve it though.

 

Capture.PNG

Hello,

Something is preventing you from connecting, but I can't say for sure what that is. At this point, since you seem to be possibly having some connection issues, maybe related to synchrony, and you mentioned a data center in the past, you might want to raise this as a ticket in our Support Portal.

You can then share with them this thread so they can follow what was done so far. If you have any trouble, let me know, and I can go ahead and raise a ticket for you.

Regards,

Shannon

Hi Shannon,

When i got to the support portal, it tells me to open a ticket here. Also, as for the above, I dont allow http connections to the confluence server, so it's definitely no mystery why those are getting blocked. I guess the real mystery is why the http requests started happening all of a sudden when I've been using solely https since the beginning?

Hello,

No worries at all; I can go ahead and create that ticket for you.

In terms of the change you made, you said you're blocking all requests? Have you set up anything to redirect them instead in case the connection is necessary?

Regards,

Shannon

Hello @Think Technologies Group,

I've created a support ticket for you now, so please check your email for that information.

It will help if you can attach a Support Zip to that ticket, as well as a copy of your recorded HAR file.

Once the issue is resolved, please feel free to update this thread with the resolution

Thank you!

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

109 views 3 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you