Lost Admin Privileges in Confluence with Crowd SSO

I updated local installation of confluence to add Crowd SSO. I've now lost all Admin privileges. I tried to disable SSO but that didn't even work. Since this is a production environment that people use, I need a solution that doesn't require a lot of downtime.

2 answers

This widget could not be displayed.

I figured out the problem. There appears to be an issue with 5.9.6. The crowd.properties file doesn't take precedence over the GUI configuration. So if you need to change this like I did because I didn't remember the crowd application password you need to update it in the gui in Crowd and Confluence first.

If you can't authenticate with Crowd, the internal directory won't work either. So I stopped Confluence, Then I got the id of the crowd directory from the DB using this query

select d.id, d.directory_name, m.list_index from cwd_directory d join cwd_app_dir_mapping m on d.id=m.directory_id;

Then I updated and verified that I disabled the Crowd directory using the following queries.

select id, directory_name, active from cwd_directory where id = 18087937

update cwd_directory set active = 'F' where id = 18087937

After that I started Crowd and was able to use my local directory admin account to log in and reconfigure the Crowd authentication.

 

This widget could not be displayed.

Hi Kevin,

have you tried to put yourself in the group "confluence-administrators" within crowd?

greetings

Benjamin

 

Benjamin,

I did try that. It didn't work at all. Also, new members added to Crowd also don't appear to be able to access confluence at all either.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published Aug 14, 2018 in Confluence

Add-on evaluation with confluence templates

Atlassian market place contains number of Apps/Addons which improves the capability of out of the box Atlassian products. It is good to follow a plugin evaluation process before install add-ons. So t...

174 views 12 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you