Livesearch Macro Not Showing Correct Results

Hi - I added a Livesearch Macro to a page I created (the page is a 3rd level child page). I restricted the search to 2 different labels (shown below). When I begin to type in the search bar, the automatic results menu that opens below the search bar shows pages that match the 2 labels. But when I click "enter" the search page returns results that do not match the 2 labels. This search page needs to be reliably accurate. Is this a bug? Can someone please help?

 

Screen Shot 2015-03-26 at 11.09.20 AM.png

1 answer

0 votes
Davin Studer Community Champion Mar 26, 2015

When you hit enter it does not pass "labelText:peoria OR labelText:indian_school" to the search results page along with your search string ... which is why you see more results than just the live search. There is a JIRA ticket for it. Feel free to add your voice to the ticket.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

183 views 2 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you