Linking Jira filter in Confluence gives no results

Hello,

I migrated a few days ago from cloud to downloaded version of Jira, JIRA Agile and Confluence.

Right now I am creating a Confluence page where I want to link the results of filter. I created a filter on JIRA and I got its ID. If I execute the filter in Jira, it gives back some issues. When I try to set up the JIRA macro in confluence, the output is "No issues found".  

This filter is visible to Everyone.

The search string is correct, in fact if I switch to a different (non existing) id, I get a different output message ("The JIRA server didn't understand your search query...").

Also, in the dropdown list on the right side of the search text, I have to values: one is "JIRA", which suppose is the link the running JIRA instance; the other is "JIRA ( myoldhostedurl.atlassian.net...) and if I select it, of course I get a 500 error.

If I paste the filter URL directly in the Confluence page, the result is still an empty list of issues. Where could be my problem?

4 answers

Manuel, I'm having the same problem!
Did you manage to resolve this?

I removed the link between the two applications and made from scratch. Before making the link, I removed from the database all references to the old server.

I tried re-creating the link many times.. but no luck. I haven't tried deleting anything from the DB, though... What do you mean by - references of the old server? Did you search the ENTIRE JIRA (or Confluence?) database? or just specific tables..? I would greatly appreciate help on this... Thanks!

After some time spent on APPLICATION LINK documentation, I figured out that I hadn't paid enough attention to the two-way application links. My flaw was on the access of Confluence to Jira, as I needed to set something like "upgrade to Application link". I am referring to the "old server" as I made a migration, which left some old links on both databases. There should be a specific documentation on this kind of issues, but I'm not sure it relates to the problem you (and I) reported.

I found this document about "How to remove Application link directly through database": https://confluence.atlassian.com/display/JIRAKB/How+to+remove+Application+link+directly+through+database I followed it to remove any any application links I have left.. but no luck. I also created the Application link with all possible permissions.. The application links seems fine, but still I'm receiving "No search results". BTW - If I ignore the "No search results" message and insert the macro anyways, then after saving the Confluence page - I can see (in the place of the macro) - only the issue count WITH A BLANK TABLE (and of course I checked in the "Display Options" that it's set to "Table" and not just "issue count")

Is the filter public/visible to the user you are authorizing the link with? However, I would recommend submitting a ticket to the Atlassian support. They may even plan on a video conference to fix the issue.

Yes, the query is public and any user can run it. I have been ping-ponging with Atlassian support for the last 5 days! No salvation there, I'm afraid... :-/

I think your user in Confluence dont have access to this filter in JIRA.
  • check application links between servers
  • login with the same user on both servers

 

login is not the reason

I triple-checked the application links, recreated them over and over again.

The user I'm using is the administrator user and he can run the same query on JIRA just fine...

Did you end up fixing this? Having the same problem.

Try to turn on the oauth authentication in both JIRA and Confluence.
In JIRA go to Application Links click Edit -> Outgoing Authentication -> Oauth and click Enable.
The same steps for Incoming Authentication in JIRA.
Also you should do the same in Confluence.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,102 views 17 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you