Linked Pages between Agile and Confluence

We have setup JIRA (including Agile) and Confluence to act as linked applications with all the "well known" old features working absolutely fine. Jira Issues Macro works as expected, both the activity stream in JIRA an the InApp Notifications in Confluence work fine. Issues show their links to confluence pages and so on ...

However nothing of the new features of Confluence 5.4.x with regards to the link features between Jira Agile and Confluence are available. Neither in the EPIC pane nor in the header areas of the sprints we see the Linked Pages feature. Only in the sprint report (and really only there) this link is available but when I click on it, JIRA tells me: No Confluence server is configured. Please check your Application Links configuration

In addition the JIRA LINKS button in Confluence is not present in any linked page, no matter if it contains a Jira Issue Macro or it is "just" linked from a JIRA issue externally.

Is there anything - besides an application link that looks okay - that I have to setup for these features to work? We have JIRA 6.1.5, Agile 6.3.8.1 and Confluence 5.4.1.

Any help will be highly appreciated.

Thanks in advance and Regards

6 answers

Hi Carsten,

In addition the JIRA LINKS button in Confluence is not present in any linked page, no matter if it contains a Jira Issue Macro or it is "just" linked from a JIRA issue externally.

It seems like you're facing this bug that's caused by the cache only updating every 5 minutes at a time.

Best Regards,
Samuel

Hi Samuel.

I checked this, but this is not the real issue. As mentioned before the JIRA LINKS button doesn't show up at all. Even not after several days now ...

Also, all link functions within the Agile Boards are missing completely. Still this seems to be unresolved and the comments on the belonging wiki pages here show that others also have this kind of problems.

I will double check all that with our sales consultant at Seibert here in Germany and as soons as I find any usefull info i will shere it here

Best Regards,
Carsten

Hello

We are using JIRA 6.1.5, Agile 6.3.8.1 and Confluence 5.4and we are encoutering the same kind of problem.

  • Jira Links button does not appear (anymore but we had it a while ago) at the top of pages containing jira issues
  • the buttons for quoting in comments and creating jira issues do not appear, or appear much lower in the page when you hover a selected text.

Does somebody know more about this problem?

Eric

I also have the same issue. I cannot create a Sprint report in confluence from JIRA directly.

I do not know if this is also related, but I cannot link a JIRA issue to a confluence page if the page has some restricted visbility, while logged on with the same user on the both sides.

However, it is possible from these restricted pages to link to new JIRA issues and the links are correctly created in the JIRA issues.

I have JIRA 6.1.7 and Confluence 5.4.2, JIRA Agile 6.3.11.0. Everything is running on the same machine, behind an NGINX webserver using SSL (cache disabled). The application link is correctly configured on both sides.

I solved the issue, after I saw these warnings in the logs of Bamboo:

2014-04-05 00:11:51,331 INFO [pool-14-thread-1] [RestCapabilitiesClient] Failed to request capabilities from 'https://my.server.url/jira/rest/capabilities': hostname in certificate didn't match: <my.server.url> != <my own name>

which points out an issue with the self-signed SSL certificate. Apparently, this occurs when the URL of the webserver is not the same as the CN of the certificate.
I reissued a new certificate with the "Common Name" is my.server.url, pushed it into the keystore, and restarted the services.

Now everything works fine again.

However, it would be nice to have proper warnings in the log files of JIRA, it would have saved me a lot of time.

I'm having a similar problem, but a bit more nuanced - The Linked Pages from the Sprint Report says that it can't find the Confluence server, but I can go to any normal issue and add a Link that uses a search of the Confluence pages. That works properly, so there's something specific to the Agile plugin, though nothing is showing up in either Confluence or JIRA logs. Any ideas on where else to look/configure?

In fact, the problem I am describing just above was impacting only Agile (I was able to link issues to confluence pages also).

Back again after waiting for our next scheduled updates ... and here we are with still the same problem.

Last weekend, I updated our system to the most recent releases of all applications hoping that this would help me out of this. Abstract of the story: it didn't ...

We now have Jira 6.3.1, Agile 6.4.3 and Confluence 5.5.4 still working behind an Apache Proxy handling the SSL part of the story. After updating everything I made a lot of tests and tried almost any workaround I could find in the knowledge base and here in the answers. All that to no avail ...

Still any kind of linking between JIRA and Confluence is working perfectly. And nothing of all that nice stuff we are shown in the "Getting Agile Ready" documents is there ... as described in my initial post my main problem is that it is even not visible! Neither the epics nor the sprints in the planning mode show the "Linked Pages" entry. Still the only place where it is visible is the sprint report and there I still get the message that there is no confluence server.

I even switched all my Confluence spaces to the new default theme instead of the old documentation theme but no change.

Yesterday morning I found the new "App Link Diagnostics" Plugin which I used extensively to test any kind of setting for the app link and in fact I found some problems. And once again, this came from the app side and not from anything I could influence. No matter what I do, I am not able to get OAuth to work! However this is not a problem for me, as we use our system only inhouse so that I can go with the Trusted Apps authentication.

BUT: while configuring all that from the JIRA side I could get the diagnostics in JIRA to show me the green flag for all settings with OAUTH "disabled". But still Confluence tried to use OAuth and escpecially the 2Legged OAuth while showing it to be disabled in the settings. I finally had to recreate the AppLink from the Confluence side (!!!) to get Confluence to understand not to use OAuth.

Now the App Link Diagnostics shows a "perfect green" on both sides, but still my Agile is absolutely not aware of my Confluence server. All this is getting a little bit frustrating now.

I will give that a last try by setting up a vanilla environment on a test machine with only demo data according to the Atlassian guides in "Getting Agile Ready" ... then we will see, if it works or when it stops working.

I have the impression that all this is coming from various SSL problems, and this is what I want to check in this test setup.

I will keep you posted on this and perhaps, someone out there might see any point in here, where I do something wrong or where he or she can help me ...

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

101 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you