Jira-Confluence Users

Hi

I have around 30 JIRA Users and about 16 of them are setup in Confluence.

Any new users I'm adding to Jira, and allowing them confluence access (confluence-users group), get a permissions violation error when they browse to the confluence section.

I've tried this for existing users as well as new users, same result – confluence throws this error: "You are not permitted to perform this operation."

I've compared permissions/user groups etc. of the users who can view confluence with those are getting this error, and there is not difference.

Is anyone else facing such an issue? Is this the right place to ask this question?

Thanks

2 answers

Hi Indy,

Your JIRA and Confluence are using same directory right ?

If yes then you can check in *Confluence Global Permission*, which group has permission to login to confluence and add user to this group. Once you identify this group then user should be able to login to confluence.

Also make sure users are login to confluence base URL for testing purpose. If users are able to login to confluence but getting permission violation on particular space or page then there might be additionally restriction set on that page which is preventing users from accessing that page.

Taha 

 

Hi Taha

We are using the cloud version of Jira. So not sure about 'same' directory as we didn't install it.

Also, I just removed the user, and recreated him with access to confluence, and still no luck. The same perms error.

Our confluence install/permissions is what comes with the default install. We haven't customized it.

The perms violation is occuring on the base url itself (not on a space inside).

It is almost as if permissions assigned to the user are somehow cached and confluence is not seeing those new permissions.

Any other thoughts?

You might ask user to clear this browser cache and cookies but I don't think it is the issue. You can check steps mentioned in this link - https://confluence.atlassian.com/display/CLOUDKB/Unable+to+Log+in+to+Atlassian+Cloud+Instance If it still doesn't work then raise the case with Atlassian.

Thanks Taha... It is not the browser cache (we've tried different browsers, incognito mode etc.). I've looked at URL you've posted and none of that applies. Can you please advise where can I raise the case with Atlassian? I can't seem to find any link to a webpage or email where I can log such a request. Thanks. Thanks for your help.

Refer this link for creating Support Ticket with atlassian - https://confluence.atlassian.com/display/Support/Creating+a+Support+Issue You need to login with your Atlassian Account here https://support.atlassian.com/customer/servicedesk-portal

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,908 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you