JIRA and Confluence on same server, can only access JIRA through browser... Edited

Hello!

My name is Markus Fredén, I appreciate you taking time reading this! 

The problem I have is that I cannot access Confluence through the browser using my domain + context path (http://mydomain.com/confluence), I can only access it via lan IP + port. However, I can access JIRA through (http://mydomain.com/)

 

I get the 404 skull;

Oops, you've found a dead link.

 

 

This is what I'm using;

Ubuntu Server v18.04

PosqreSQL v9.4.14

Java v1.8.0_144

Apache v2.4.25

JIRA Software v7.3.4

Confluence v6.3.3

 

Port 80 is allowed through router fw and DNS settings are in place. And for what it's worth I did not have to forward any ports for JIRA (e.g. 8080).

ufw is off.

proxy_http module enabled:

2enmod proxy_http

Set context path and also added this:..

 proxyName="mydomain.com"
proxyPort="80"
scheme="http"

...to my confluence server.xml

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<Connector port="8090" connectionTimeout="20000" redirectPort="8443" maxThreads="48" minSpareThreads="10" enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8" proxyName="mydomain.com" proxyPort="80" scheme="http" protocol="org.apache.coyote.http11.Http11NioProtocol" />

<Engine name="Standalone" defaultHost="localhost" debug="0">

<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
<Context path="/confluence" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
<!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
<Manager pathname="" />
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>

<Context path="${confluence.context.path}/synchrony-proxy" docBase="../synchrony-proxy" debug="0" reloadable="false" useHttpOnly="true">
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>
</Host>

</Engine>
</Service>
</Server>

 

This is my Apache site conf (/etc/apache2/sites-available/000-default.conf):

<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ServerName mydomain.com

ProxyRequests Off
ProxyVia Off
ProxyPreserveHost On

<Proxy *>
Require all granted
</Proxy>

ProxyPass / http://localhost:8080/
ProxyPassReverse / http://mydomain.com:8080/

ProxyPass /confluence http://localhost:8090/confluence
ProxyPassReverse /confluence http://mydomain.com:8090/confluence

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf
</VirtualHost>

 

Also tried adding a new apache site conf like this (With same value as in 000-default);

a2dissite 000-default
vi /etc/apache2/sites-available/new-site.conf
a2ensite new-site.conf

 

What could I have missed? Any suggestions are greatly appreciated!

Best regards,

Markus Fredén

2 answers

2 votes

Hi Markus,

Note: this might not answer your question but just provides a recommendation :)

Please note we do not recommend running JIRA and Confluence together on the same server. Refer to the doc at https://confluence.atlassian.com/conf57/installing-confluence-and-jira-together-701435562.html

Thank you

Bhushan

I actually got this working in another thread that I posted because I thought that this one didn't get posted.

 

Anyways, here is it;

https://community.atlassian.com/t5/Confluence-questions/Multiple-Atlassian-applications-under-same-domain/qaq-p/636496#M85670

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in New to Confluence

How to use Confluence Cloud for stakeholder management

Most of us don’t need much convincing that stakeholder management is important. It just makes sense that keeping everyone in-the-know on projects and assigning clearly defined roles is key to having ...

1,202 views 4 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you