JIRA Fisheye Application Link via SSL (SSLHandshakeException, EOFException)

Hello everybody,

I recently updated our staging JIRA to the newest version (5.2.7) and try to integrate it with staging FishEye (2.7.12) via SSL (both of them are available via https and work so far).

When I try to create an application link between them, I'll get some exceptions in the FishEye log:

2013-02-27 07:55:29,684 WARN  [btpool0-3 ] mortbay.log Slf4jLog-warn - EXCEPTION 
javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:849)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1170)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1197)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1181)
	at org.mortbay.jetty.security.SslSocketConnector$SslConnection.run(SslSocketConnector.java:708)
	at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)
Caused by: java.io.EOFException: SSL peer shut down incorrectly
	at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:333)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:830)

The error messages on the GUI of FishEye is "The host is unknown. Verify that the URL is correct."

At first I assumed there's a problem with the keystore and the truststore, both applications point to the same keystore and this keystore is also configured as truststore. So that might not be the problem. The second idea I had is the whitelist-restriction of JIRA => I configured the FishEye URL there, but also that gave me no success.

Do you have an other idea what I can try?

Maybe there's a version-conflict (JIRA 5.2.7 and FishEye 2.7.12) => I'll try that later on. The staging Confluence (5.0) points also on the same keystore/trustsure and the application link betweein JIRA<->Confluence works.

*Update*

The Remote-API of both applications is ON, so that's not the problem too :(

3 answers

1 accepted

This widget could not be displayed.

Finally (after hours of java-ssl-keytool/openssl pain) it works!

The problem were different kinds of certificates used for JIRA/Confluence & FishEye. I dropped the keystore, created 3 fresh SSL certificates and all works now as expected ;)

This widget could not be displayed.
Janet Albion Atlassian Team Feb 26, 2013

Hi,

It's seems that you have both JIRA and FishEye installed in the same server. It's also referring to the same keystore and trust store.

This widget could not be displayed.

Hello,

thanks for your fast response:

* FishEye, JIRA & Confluence are running on the same machine (all https, same keystore & truststore) - each of them are running https on a different ip address and name aliases (devfisheye, devjira, devconfluence)

* The firewall of anti-virus (kaspersky) is disabled, the Windows firewall is also disabled, so there should be no problem

* I tried SSLPoke with all constellations:

** java -Djavax.net.ssl.truststore=... SSLPoke localhost 443 => "Successfully connected"

** java -Djavax.net.ssl.truststore=... SSLPoke devjira 443 => "Successfully connected"

** java -Djavax.net.ssl.truststore=... SSLPoke devconfluence 443 => "Successfully connected"

** java -Djavax.net.ssl.truststore=... SSLPoke devfisheye 443 => "Successfully connected"

* Meanwhile I upgraded the FishEye version from 2.7.12 to 2.10.2 and the error message on creating the application link changed a bit: "The host doesn't respond. Change the URL or click Next to confirm."

But nevertheless it does not work yet :/

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

603 views 8 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you