Issue saving an edited file using NeoOffice back to Confluence

Hi there,

I read the following article indicating how to use the Office Connector for Confluence Ondemand and how to edit MS-Word documents directly from a Confluence page and then save the changes back into Confluence and overwrite the same file in Confluence, which does accelarate collaboration on MS Office documents using Confluence, as follows:

https://confluence.atlassian.com/display/CONF41/Installing+the+Firefox+Add-On+for+the+Office+Connector

but I have an issue when saving the MS-Word document after editing, the details are as follows.

Scenario: when I try to edit a MS-Word document stored inside a page in one of my spaces on Confluense, I am able to open the document and visualize it using the application NeoOffice which is installed on my MacBook Pro, but after I make a couple of changes and I try to close the NeoOffice, then application NeoOffice asks if I want to save the document (obviously because of the changes made to the document).

Issue: when I select to save it with the changes, hoping it will be saved back to Confluence where the original document is stored and where the document actually comes from, but I get the following error:

"[!] Error saving the document RFQ1149LogiCoverLetter: General Error. General input/output error".

I followed the exact instructions but I am not sure why I have problems to save the document back to Confluence.

Environment: I am using the Confluence Ondemand (hosted by Atlassian) and I am using the Office Connector that comes with it. My machine is a Apple MacBook Pro running OS X (Lion), and I am using the web browser Firefox 15.0.1 for Mac and I do have the plug-in for WebDAV installed. I did not configure anything in the WebDAV, it was just installed automatically the first time I tried to open a MS-Word document and I did not change any configuration so far until now.

Please, can someone help by providing guidance on where the issue could be and how to fix this problem?

Thanks in advance!

2 answers

0 votes

Please be aware that Atlassian Answers is not an issue tracker or a offical Support channel from Atlassian, this is a community based site.

I would recomment that you open a Support request at https://support.atlassian.com so this can be diagnosed properly.

There was a bug that was affecting OnDemand Confluence https://jira.atlassian.com/browse/CONF-26911

The problem you're seeing could still be related to that.

Best Regards,
Felipe Cuozzo
OnDemand Team

Yes, I have opened a new ticket with Atlassian but I haven't heard back yet. The surprising thing is that this was working before and it looks like after an update back in October/2012 was put in (as described in the JIRA ticket mentioned by Felipe [Atlassian]) this issue start to happen to many Confluence users using the On-demand webiste hosted by Atlassian. I am still not sure if the ticket has been resolved, even though it shows as "Resolved" (see the link in Felipe's message), but I still experience the issue today.

I will wait for Atlassian to manifest themselves about this and I will update this ticket with the outcome. So, if you have a similar issue, please report to Atalssian as this seems to be a bug in the On-demand platform, and I hope they will find a fix quickly.

Thanks!

The Confluence team pointed me to this other bug: https://jira.atlassian.com/browse/CONF-25594

I'll keep an eye on your support case.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in New to Confluence

How to use Confluence Cloud for stakeholder management

Most of us don’t need much convincing that stakeholder management is important. It just makes sense that keeping everyone in-the-know on projects and assigning clearly defined roles is key to having ...

1,143 views 4 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you