Integrating Confluence with a Jira installation on a different server

Initially we had both our Jira and Confluence installations on the same machine and integration bewteen the two worked fine. However, I've had to move Confluence to a different server for various reasons, and now when I try and use Jira for use administration it doesn't work.

When I enter http://my.jira.com:8080 (our Jira base URL) into the integration wizard I get an error saying "This is not a valid url for JIRA 4.3 or later". I have no idea what is casuing this, since it was working when they were on the same system and I've verified the user information is correct. I'm running Confluence 4.0.

Thanks

5 answers

1 accepted

This widget could not be displayed.

I wound up just moving the Jira installation to the same system as Confluence. I was able to access both the Jira and Confluence servers on the correct ports when they were still seperated. I didn't try using the IP, but I don't think that would have worked since then inserting Jira issues into Confluence pages would not have worked correctly, since they would use that IP instead of the correct URL.

Thanks for the help.

This widget could not be displayed.

This is probably due to network problems between the servers. Is there a firewall in between or on one of the servers that is blocking traffic? Can you access one server from the other on the correct port (8080)?

This widget could not be displayed.

In a browser from the new confluence box browse to Jira using your address. It's likely to fail, if it does use the IP address of the Jira box instead of the DNS name. Don't forget to add the port number when you test it.

This widget could not be displayed.

I had this problem with JIRA 5.0.6 and Confluence 4.2.5 as well. Dempset Moore and Sander Brienen are correct in looking for the connectivity issue. I get the impression that the error message is a bit of a red herring and that most people receive the "This is not a valid url for JIRA 4.3 or later" error due to a networking issue.

In my case, because I am on a private network doing standalone installations one one machine, I needed to update my hosts file to recognize the hostname of the server. Kind of weird, but it worked.

I am running 64 bit FreeBSD 9 with no troubles so far into Stage 3 of the Dragon Quest.

Cheers,
Joe

This widget could not be displayed.

Solved in my case by following : Unable to Add Application Links via HTTPS

  • JIRA runs on JAVA6, public IP (https://domain.tld:port) under /home/jira user account, self-signed certificate, imported in ".keystore"
  • CONFLUENCE runs on JAVA7 (same server) on a VPN IP (http://10.1.1.2:anotherport), under '/home/confluence' user account.

All that was needed to enable both :

  • `configuration` ➔ `répertoires utilisateurs`
  • `administration` ➔ `application links

was to :

  1. add JIRA's self-signed SSL cert to 'confluence' user's keystore : in "/user/confluence", execute "$JAVA_HOME/bin/keytool -import -alias tomcat -file /home/jira/file.cer"
  2. then, to confluence's "setenv.sh", add "-Djavax.net.ssl.trustStore=/home/confluence/.keystore" to the firts "JAVA_OPTS" line

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

135 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you