Installing Confuence on EC2 Red Hat

I installed atlassian-confluence-5.1.4-x64.bin on Red Hat 6.4 on EC2 using the Express Install option. Confluence is starting automatically wityout errors:

Jul 03, 2013 6:13:38 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
Jul 03, 2013 6:13:40 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
Jul 03, 2013 6:13:40 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
Jul 03, 2013 6:13:40 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
Jul 03, 2013 6:13:40 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090
Jul 03, 2013 6:13:40 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 3247 ms
Jul 03, 2013 6:13:40 PM org.apache.catalina.core.StandardService start
INFO: Starting service Tomcat-Standalone
Jul 03, 2013 6:13:40 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
2013-07-03 18:13:55,753 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.1.4 [build 4249 based on commit hash 84a11b3502ae79dd6028856f37ff89838963c1cc]
Jul 03, 2013 6:14:23 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090
Jul 03, 2013 6:14:23 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 42855 ms

I've created a custom rule for port 8090 / 0.0.0.0/0 in the instance's security group, but I don't get any response at http://<public DNS name for instance>:8090. I know the public DNS name I'm using is correct since I can ssh to it.

Maybe I need to modify the Confluence base URL? How do I do that at the command line?

3 answers

1 accepted

2 votes
Accepted answer

I had to run system-config-firewall-tui to customize the Red Hat firewall to allow HTTP and tcp over port 8090.

Some additional notes on this:

Installation on t1.micro failed because it was too small, started over with m1.small.

Before creating instance, create key pair so you have the locally stored portion of the key. and edit security group to enable ssh.

Once instance has initialized open a terminal.

cd to directory with .pem key file

ssh -i <file>.pem ec2-user@<public DNS name for EC2 instance>

sudo sh

yum install system-config-firewall-tui

system-config-firewall-tui

- select customize, enable tcp over port 8090

cd /tmp

Download the .bin file for the appropriate installer, e.g.:

wget www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-5.1.4-x64.bin&version=5.1.4&usertype=trial

Once download is complete, make executable and run:

chmod a+x atlassian-confluence-5.1.4-x64.bin

Run the installer:

./atlassian-confluence-5.1.4-x64.bin


Thanks for taking the time to post your solution.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

60 views 3 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you