Installing Confluence Server on a Mac

I currently have Confluence server installed on a Linux VPS but I want to install it locally on my Mac to lower costs. Is this even possible? According to the documentation I can't find anything on this.

4 answers

2 accepted

1 vote
Answer accepted

Hello Marc,

It is possible to install Confluence on a mac, but only for evaluation purposes. You can't run your production on it, as outlined in Supported Platforms page.

If you want to proceed with evaluation, you can follow Installing Confluence on Linux from Archive File guide

Regards,

Igor

Hi Igor,

 

First of all, WOW, that’s an insanely fast reply :-)

 

I’ve been running Confluence on a VPS Linux server for almost a year now do I don’t need to evaluate it. I just want to cut costs for now and remove the VPS as I mostly use Confluence for myself right now to generate Wiki pages which I then send to my customers (without the collaberation bit). 

 

That’s why I was looking to install it on my Macbook. But if I understand you correctly, this isn’t possible and I am left with the choice of keeping my VPS (with additional costs), switching to Cloud Confluence or setting up a Linux or Windows machine at home to install Confluence Server on right? Would it be possible to use Windows emulation software on my Mac to keep using it or is there another way?

Hey @Marc Maessen,

Sorry that this reply came late :D 

I did not say it's not possible, merely it's not supported, this means we can't guarantee stability or performance due to unpredictable OS related behavior. So it will still work and you can install and you should have no issues with using it this way for personal needs, but if you encounter technical issues, you may have to switch to something that is supported. So go ahead, install and test the stability, i have multiple instances running for testing purposes on my mac without any issues.

For emulation, I don't think it will work too well either, you may as well just install it directly on mac, would be more stable. alternative setup, is to use a docker container, if you are familiar with that, you can find more details here Official Confluence Server image. Our support team will be able to assist you with any confluence related problems you would encounter when running on docker, but you would have to be confident in managing docker portion of setup yourself.

Hope this helps

I did the following after downloading the atlassian-confluence-6.10.0-x64.bin file

:

1 - chmod a+x atlassian-confluence-6.10.0-x64.bin

2 - sudo ./atlassian-confluence-6.10.0-x64.bin


On my Mac in Terminal I get the following error message after step 2:

 

Unpacking JRE ...

Starting Installer ...

./atlassian-confluence-6.10.0-x64.bin: line 574: /Users/marcmaessen/Downloads/atlassian-confluence-6.10.0-x64.bin.9747.dir/jre/bin/java: cannot execute binary file

 

 

I must be doing something wrong here which is probably blatantly simple, but I can't see it...

Any ideas? 

Hey @Marc Maessen,

You can't install bin types of files on mac, I believe, it will not recognise them it due to dozen or so  security restrictions on macs. 

You need to follow Installing Confluence on Linux from Archive File guide. In summary:

  1. Create a dedicated "confluence" account
  2. Create new install dir
  3. Extract tar.gz archive contents into install dir
  4. Give permissions to install dir to "confluence" account
  5. Create new home directory
  6. Modify system properties file from instal dir to point to new home
  7. Verify default ports of 8090 and 8091 can be used, if you want custom, modify server.xml file
  8. Use <installation-directory>/bin/start-confluence.sh to start confluence 
  9. Access it via localhost:port and proceed with setup

Hope this helps

Igor

Hi Igor,

 

I can't seem to access Confluence via the localhost. Please see detailed reply below to the post of Ann. I created a dedicated Confluence account and followed every step you mentioned precisely

0 votes
Answer accepted

Hi Marc,

My two cents:

  1. Set JAVA_HOME on your Mac to a supported version.
  2. Create an external database per the doc for your DBMS.
  3. Expand the tar.gz archive of Confluence.
  4. Edit <confluence_install>/confluence/WEB-INF/classes/confluence-init.properties to define Confluence Home - the setup will create this directory but make it different from the directory where you expanded the tar.gz.
  5. Use Terminal to start Confluence with sudo at <confluence_install>/bin/start-confluence.sh.
  6. Open the setup wizard in a browser at http://localhost:8090.
  7. Step through the setup wizard to complete the setup.

I hope this works as well for you as it does for me.

Cheers,

Ann

Hi Ann,

It's been a while and it took some trial and error to get there, but I managed to do every step you mentioned up until step 6. When I try to start Confluence I get the following message:


---------------------

To run Confluence in the foreground, start the server with start-confluence.sh -fg

executing as current user

If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide

 

Server startup logs are located in /Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/catalina.out

---------------------------------------------------------------------------

Using Java: /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home/bin/java

2018-08-08 13:43:45,792 INFO [main] [atlassian.confluence.bootstrap.SynchronyProxyWatchdog] A Context element for ${confluence.context.path}/synchrony-proxy is found in /Users/Confluence/Documents/atlassian-confluence-6.10.1/conf/server.xml. No further action is required

---------------------------------------------------------------------------

Using CATALINA_BASE:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_HOME:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_TMPDIR: /Users/Confluence/Documents/atlassian-confluence-6.10.1/temp

Using JRE_HOME:        /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

Using CLASSPATH:       /Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/bootstrap.jar:/Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/tomcat-juli.jar

Using CATALINA_PID:    /Users/Confluence/Documents/atlassian-confluence-6.10.1/work/catalina.pid

Existing PID file found during start.

Removing/clearing stale PID file.

Tomcat started.



---------------


After this, when I try to open the setup wizard at Localhost:4380 (an open port which I edited in the server.xml file) it just keeps loading, nothing happens and no setup wizard launches.

Any thoughts where to look next?

removed comment, solved due to incorrect java version

Removed comment, problem solved due to incorrect java version

As Ann says, "Set JAVA_HOME on your Mac to a supported version."

jdk-10 is not a supported version.  See https://confluence.atlassian.com/doc/supported-platforms-207488198.html

Ah d*mn... Can't believe I missed that...

I'll try again and this time with Java 1.8

 

Sorry

 now have the correct Java 1.8 set as my Home version (checked when executing echo $JAVA_HOME

/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home

 

I did this by adding the following

JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home

PATH=$JAVA_HOME/bin:$PATH

 

to 

etc/profile

and

~/.bash_profile

 

***************

 


Now when I start Confluence, it states:

To run Confluence in the foreground, start the server with start-confluence.sh -fg

executing as current user

If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide

 

Server startup logs are located in /Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/catalina.out

---------------------------------------------------------------------------

Using Java: /Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/bin/java

2018-08-09 14:58:23,850 INFO [main] [atlassian.confluence.bootstrap.SynchronyProxyWatchdog] A Context element for ${confluence.context.path}/synchrony-proxy is found in /Users/Confluence/Documents/atlassian-confluence-6.10.1/conf/server.xml. No further action is required

---------------------------------------------------------------------------

Using CATALINA_BASE:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_HOME:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_TMPDIR: /Users/Confluence/Documents/atlassian-confluence-6.10.1/temp

Using JRE_HOME:        /Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home

Using CLASSPATH:       /Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/bootstrap.jar:/Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/tomcat-juli.jar

Using CATALINA_PID:    /Users/Confluence/Documents/atlassian-confluence-6.10.1/work/catalina.pid

Existing PID file found during start.

Removing/clearing stale PID file.

Tomcat started.

-------------

 

However, after loading localhost it just keeps loading again and shows no error. 


********************

 

Catalina.out log contains:

NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED

[0.002s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/Users/marcmaessen/Downloads/atlassian-confluence-6.10.1/logs/gc-2018-08-08_13-15-17.log instead.

Unrecognized VM option 'UseGCLogFileRotation'

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED

[0.002s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/gc-2018-08-08_13-34-09.log instead.

Unrecognized VM option 'UseGCLogFileRotation'

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED

[0.002s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/gc-2018-08-08_13-35-01.log instead.

Unrecognized VM option 'UseGCLogFileRotation'

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED

[0.002s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/gc-2018-08-08_13-37-24.log instead.

Unrecognized VM option 'UseGCLogFileRotation'

@Ann Worley / @Igor Muzaliov

Do you have any idea what I could do next based on the information in this latest reply? I'm kinda stuck at the moment to be honest...

 

------

 

 

Addendum:

Don't know if this might be the cause of something as I've tried starting Confluence using my regular OSX admin account and the new Confluence account, but both result in the same loading page:

I've edited the /etc/profile for all users and .bash_profile for both my regular account and the new Confluence account. However, when starting confluence through my regular account I can see it's using java 1.8 as stated in the reply above, but when starting it using the Confluence account it's still using java 10 for some reason. If this could even have some sort of impact, is there another place where it could be set? 

Hey @Marc Maessen

JAVA_HOME is set a bit differently on a mac than it is on normal Linux, can you check with this too:

/usr/libexec/java_home -V

Also are you launching confluence via <installation-directory>/bin/start-confluence.sh by just running the script, not sudo it?

Regards,

Igor

Hi @Igor Muzaliov

These are my results:

/usr/libexec/java_home -V

Matching Java Virtual Machines (4):

    10.0.2, x86_64: "Java SE 10.0.2" /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

    1.8.0_181, x86_64: "Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home

    1.6.0_65-b14-468, x86_64: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

    1.6.0_65-b14-468, i386: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

 

/Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

 

It seems I have too much installed / configured, but I have searched for how to remove Java from my Mac and nothing seems to work? Do you know a guaranteed method to either remove all Java versions except SE 8, or in worst case remove them all so I can install only SE 8 back again?

 


Lastly in regards to your question: I'm launching Confluence by sudo su to the Confluence user account, then going to the <installation-directory>/bin/ directory and executing ./start-confluence.sh

 

By the way: Is this something which I would always have to do after a reboot in order to get Confluence back up and running ?


Thanks again for your time and help !

Hey,

Yes, that is quite a few runtime environments.
Let's start from simply answer, you can configure Confluence to always run with a dedicated account, even if you are just executing it as local.
The <Confluence_Install>/bin/start-confluence.sh script uses a variable, CONF_USER which is set in <Confluence_Install>/bin/user.sh.
To change the user the script will use to run Confluence, follow this guide: How to Change the User starting Confluence with start-confluence.sh script

In summary,

  • Edit <Confluence_Install>/bin/user.sh:
# START INSTALLER MAGIC ! DO NOT EDIT !
CONF_USER="confluence" ##
# END INSTALLER MAGIC ! DO NOT EDIT !
export CONF_USER
  • Replace "confluence" with the user you would like to run Confluence.

From here, running the script with your local account should start Confluence with a dedicated one.

 

In regards to environments, there should be no need to delete other runtime environments, especially that mac interprets them a bit differently and not all that is installed is actually a jre.

Could you try modifying ~/.bash_profile file with the following:

export JAVA_HOME="/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/jre"

do not add anything else then Reload the environment variables:

. ~/.bash_profile
echo $JAVA_HOME

With dedicated start account setup and variables pointing to jre, your instance should start correctly. Let me know how it goes

Regards,

Igor

Hi @Igor Muzaliov,

First of all, again, many MANY thanks for trying to help me out here. Especially since i realise that what I'm asking is officially not supported and I'm asking things which are way beyond the 'call of duty' here. You have no idea how much I appreciate all the time and effort you're putting into these answers !! Thank You !

I followed all the steps you mentioned, and my bashprofile looks just like you stated. When I echo $JAVA_HOME it shows me the 1.8 version correctly, but for some reason when I now want to start Confluence, it gave me this message:


"To run Confluence in the foreground, start the server with start-confluence.sh -fg

Confluence has been installed to run as Confluence so please sudo run this to enable switching to that user"



So I switched to the Confluence user (sudo su Confluence) and tried starting it from there. This gave me the following Permission denied message and it still shows it's using the 10.0.2 version for some reason...

 

 

"To run Confluence in the foreground, start the server with start-confluence.sh -fg

./start-confluence.sh: line 39: ./user.sh: Permission denied

executing as current user

If you encounter issues starting up Confluence, please see the Installation guide at http://confluence.atlassian.com/display/DOC/Confluence+Installation+Guide

 

Server startup logs are located in /Users/Confluence/Documents/atlassian-confluence-6.10.1/logs/catalina.out

---------------------------------------------------------------------------

Using Java: /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home/bin/java

2018-08-15 06:31:42,090 INFO [main] [atlassian.confluence.bootstrap.SynchronyProxyWatchdog] A Context element for ${confluence.context.path}/synchrony-proxy is found in /Users/Confluence/Documents/atlassian-confluence-6.10.1/conf/server.xml. No further action is required

---------------------------------------------------------------------------

Using CATALINA_BASE:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_HOME:   /Users/Confluence/Documents/atlassian-confluence-6.10.1

Using CATALINA_TMPDIR: /Users/Confluence/Documents/atlassian-confluence-6.10.1/temp

Using JRE_HOME:        /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

Using CLASSPATH:       /Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/bootstrap.jar:/Users/Confluence/Documents/atlassian-confluence-6.10.1/bin/tomcat-juli.jar

Using CATALINA_PID:    /Users/Confluence/Documents/atlassian-confluence-6.10.1/work/catalina.pid

Existing PID file found during start.

Removing/clearing stale PID file.

Tomcat started." 

 

 

My user.sh looks like this:

# START INSTALLER MAGIC ! DO NOT EDIT !
CONF_USER="Confluence" ##
# END INSTALLER MAGIC ! DO NOT EDIT !

export CONF_USER

 


And to complete the picture, my server.xml file under the conf directory looks like this 

 

"

<Server port="4370" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<!--
==============================================================================================================
DEFAULT - Direct connector with no proxy, for unproxied HTTP access to Confluence.

If using a http/https proxy, comment out this connector.
==============================================================================================================
-->
<Connector port="4380" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"/>

....

"

 

I changed to these ports as the default ones were not available and these were. So I'm trying to start Confluence in a browser with http://localhost:4380/

 

 

 

My dedicated Mac account where the install files are located is called "Confluence" and the install files are located in the Documents folder of that user as shown here:

http://fileshare.onlineprofilecoach.nl/3i1U0L113b2L



Is there perhaps a way to clean start with this whole Java thing or something?

That about summons up all the info I can give you as far as I know. And I realise I'm a complete newbie at all this so again Thank You so much for all you're doing here !

Kind regards,

Marc

Hello,

That is not a problem.

I suspect the trouble with starting is because confluence is installed under other users home folder, macs can be a pain for that. 

Few things I wanted to ask,

  • Would it be possible to move it to some neutral location?
  • For the testing purpose, can you give yourself execute rights on startup scripts, specifically /user.sh
  • Finally, what is a long-term goal for your confluence, if you will only be using it locally on your mac, for "evaluation" then there is no real need for you to have it running as dedicated user. Generally, the recommendation for that is as a security precaution when Confluence is installed on the server and accessed by a lot of other users. you just planning to use it yourself, it might be easier to just installed it for yourself.

Let's try to remove that pesky Java 10 and hope next in line, which is Java 1.8 become defacto environment. You can try the following:

cd /Library/Java/JavaVirtualMachines

ls to see which environments you have there

and then remove the not necessary one:

sudo rm -rf jdk-10.0.2.jdk

 You can do the same for 1.6 unless you have some application that requires it.

Lastly, there are these Start Confluence Automatically on Linux instructions that should allow you to configure confluence to run as service on Linux, not sure how applicable they are for mac, i haven't tested it, all my instances are running with manual startup, but at the same time, i am not using dedicated account, I just use my own.

P.S. you might need to reboot your mac after java removal for the environment to reload properly.

Hi again @Igor Muzaliov,

Some Background information first perhaps:

I have been a Confluence Administrator at 2 jobs now for more then 3 years. I love the flexibility and collaboration it offers combined with the extreme easy of use. I have installed the server edition manually at one occasion, installed it manually on my own currently hosted Virtual Private Linux server and am now trying to install it manually on my Macbook. I’m not a tech guru by any means, but I do know enough to usually get things working. Linux (and thus OSX) is a bit of a black box for me though, that’s why I’m asking you for help :-)

My short term goal is to use Confluence on my own in order to easily generate web pages for my static wiki site for customers. I have a full-time job and have started a small business on the side to see if it'll work out. For this small business, I'm using Confluence to generate wiki pages much more easily then I could've otherwise done. Thanks to all the amazing plugins, things like flow charts, export to PDF and copying an entire set of pages or even a space to a new one and renaming the client name automatically everywhere are so much easier in Confluence then any other tool I know.

I realise this is undermining the entire collaboration section which is the heart of Confluence basically, but for my own business in it's current state this is all I need and if I get it up and running on my Mac, then I can use it without any further additional costs like the VPS Linux server I'm paying for right now which hosts it. In the future, I hope that I can use it even more broadly again and even have clients use it as well. So my long term plans if things pan out is to export everything from my mac to another hosted VPS Linux server and work in Confluence with my clients. 

But for now, as a solo-preneur, just getting it up and running on my Mac for my account and my use only is my main focus as this would allow me to continue to reap the benefits of this amazing tool :-)



Ok so in any case (and I'm adding screenshots to be sure I got everything right):

  • I moved the install dir and Confluence Home dir to the root at /Confluence and changed the Home dir to that directory in the conflience-init.properties too
    http://fileshare.onlineprofilecoach.nl/2z47092h021H

  • I removed the Confluence user entirely and also removed it from the user.sh which now looks like this again
    http://fileshare.onlineprofilecoach.nl/0p2O3H2x1U04

  • I removed all Java versions except 1.8 
    http://fileshare.onlineprofilecoach.nl/0I1v2L0M442U

  • I'm not sure how to give myself execute rights on the user.sh though. This is the current setting and as far as I can see, since my marcmaessen account is an Admin account and I should therefor be included in the wheel group (if I understand this all correctly), then I should already have execute rights:
    http://fileshare.onlineprofilecoach.nl/053Y1g2K1L0Y

  • I don't need to run it permanently as a service. Considering my current use case which I described above, each time I would want to run Confluence I'm happy to start it manually with my own account as well (just to confirm, this would mean going to the bin directory in Terminal and executing the start-confluence.sh script, then loading the localhost in a browser right?)

 

After all this, I rebooted my Mac and tried running the start-confluence.sh script from Terminal with my own user again with these results:

 

http://fileshare.onlineprofilecoach.nl/3T1800132s2p

 

 

 

So as far as I can tell, everything seems to be looking just fine now. However when loading localhost:4380 then nothing happens and I get a ‘Not Found’ message. I set this port in the server.xml file :

http://fileshare.onlineprofilecoach.nl/1N441v0P451N

 

since these were indicated as currently open ports for me:

http://fileshare.onlineprofilecoach.nl/3m2V0T2K1K3h

 

The new thing is that in the Confluence Home folder, logs have been created:
http://fileshare.onlineprofilecoach.nl/1r241s0E1a2R

 

The atlassian-confluence.log shows:

2018-08-17 08:52:47,840 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.10.1 [build 7702 based on commit hash c32f84c806260a834c2e109e904a2d8ee4f8e175] - synchrony version 2.1.0-master-ed94c233
2018-08-17 08:52:55,423 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun
2018-08-17 08:52:59,599 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] logTime Plugin system earlyStartup ended
2018-08-17 08:52:59,605 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] lateStartup Plugin system lateStartup begun
2018-08-17 08:53:01,362 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] logTime Plugin system lateStartup ended
2018-08-17 08:53:02,646 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2018-08-17 08:53:02,753 FATAL [localhost-startStop-3] [atlassian.spring.container.SpringContainerContext] getComponent Spring Application context has not been set
2018-08-17 08:53:02,766 WARN [localhost-startStop-3] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextDestroyed Failed to shut down plugin system during ServletContext shutdown: Spring Application context has not been set
2018-08-17 08:53:02,771 INFO [localhost-startStop-3] [com.atlassian.confluence.lifecycle] contextDestroyed Stopping Confluence
2018-08-17 08:53:02,859 INFO [localhost-startStop-3] [atlassian.plugin.manager.DefaultPluginManager] shutdown Preparing to shut down the plugin system
2018-08-17 08:53:02,860 INFO [localhost-startStop-3] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system 

 

Allright, I’m at a point again where I wouldn’t know how to proceed. My feeling tells me the 'getComponent Sprint Application context has not been set'  error is now the cause. So I googled that and will continue with these steps tomorrow or perhaps later today again:

https://confluence.atlassian.com/confkb/confluence-does-not-start-due-to-spring-application-context-has-not-been-set-218278311.html 


But to bo honest I hope all these screenshots and this information can help you determine where my bottleneck is in my current setup before I get to that :-)

Many thanks again !!!

Hello,

Awesome and thank you for the screenshots. 

You definitely on the right track for the KB, but there are 10 different reasons for that message during startup. Most typical one is file permissions, however, it would be best to move this into a support ticket for easier communication. I have opened one for you and we will take our investigation there. You should soon receive a reply there

The issue was fixed in the ticket after the following steps:

  • Moved installation directory to a neutral location and changed all ownership to the primary user logging into mac
  • Deleted confluence.cfg.xml as well as plug-ins cache and indexing directories from home
  • After checking catalina.out logs discovered that tomcat was failing to start due to port already being in use, either by old process or some other app, so changed ports from server.xml and made sure to kill all other processes

After the above steps application started without further issues.

0 votes
Max Bern Atlassian Team Jul 10, 2018

You could also investigate using Docker, whilst Docker for MacOS isn't the best implementation, this could work for your use case. A command such as the below would work:

docker run --restart=unless-stopped -v $HOSTPATH:/var/atlassian/application-data/confluence --name="confluence" -d -p 8090:8090 -p 8091:8091 atlassian/confluence-server

 You can find more on the this quick start here, and more about docker for Mac here.

You'll need docker installed, and the use of a Volume ( the -v command ) to enable data persistence. You can optionally change the tag in the command if you need a specific version such as "docker pull atlassian/confluence-server:latest"

Many, MANY thanks for all the effort and the detailed replies Igor, Max AND Ann (just wow !!)

I don't have a lot of time the next few days, but I will try all your amazingly detailed suggestions and will keep you posted on my progress. It'll probably be sometime halfway through next week until I've had the time to try everything out (unless the first attempt is directly successful).

Many thanks again thusfar in any case !!!

@Marc Maessen you are very welcome!

Could you mark answers as "Accepted" solutions so that others who come across this thread will know that issue got resolved?

Regards,

Igor

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

297 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you