Impossible to install plugins: Failed to resolve plugin dependencies within OBR

Hi,

I've upgrade confluence to version 5.6.6 and I have the bad surprise to be not able anymore to install any plugins, having issues with OBR dependencies...

  • My UPM is up-to-date to the lateste version and I cannot do anything on this side.
  • My server is running Java version 1.8.045

current stack I get when I try to install any plugin:

-- url: /rest/plugins/1.0/installed-marketplace | referer: https://confluencetest.bsb.com/plugins/servlet/upm | userName: scs
2015-07-24 09:48:14,363 WARN [UpmPacClient:thread-42] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- url: /rest/plugins/1.0/installed-marketplace | referer: https://confluencetest.bsb.com/plugins/servlet/upm | userName: scs
2015-07-24 09:48:14,363 WARN [UpmPacClient:thread-39] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- url: /rest/plugins/1.0/installed-marketplace | referer: https://confluencetest.bsb.com/plugins/servlet/upm | userName: scs
2015-07-24 09:49:43,020 WARN [ajp-8010-1] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- referer: https://confluencetest.bsb.com/plugins/servlet/upm | url: /rest/plugins/1.0/com.atlassian.upm.atlassian-universal-plugin-manager-plugin/marketplace | userName: scs
2015-07-24 09:49:58,302 WARN [ajp-8010-4] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- url: /rest/plugins/1.0/available/ch.bitvoodoo.confluence.plugins.viewtracker-key/review | userName: scs | referer: https://confluencetest.bsb.com/plugins/servlet/upm
2015-07-24 09:50:02,317 INFO [ajp-8010-4] [atlassian.plugin.manager.DefaultPluginManager] disableDependentPlugins Found dependent enabled plugins for uninstalled plugin 'ch.bitvoodoo.confluence.plugins.viewtracker': []. Disabling...
2015-07-24 09:50:02,317 INFO [ajp-8010-4] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling ch.bitvoodoo.confluence.plugins.viewtracker
2015-07-24 09:50:03,521 WARN [ajp-8010-4] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- url: /rest/plugins/1.0/ch.bitvoodoo.confluence.plugins.viewtracker-key | userName: scs | referer: https://confluencetest.bsb.com/plugins/servlet/upm
2015-07-24 09:50:22,193 WARN [UpmAsynchronousTaskManager:thread-1] [http.impl.auth.HttpAuthenticator] generateAuthResponse NTLM authentication error: Credentials cannot be used for NTLM authentication: org.apache.http.auth.UsernamePasswordCredentials
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements OBR resolver has 60 unsatisfied requirements for installing plugin.3846778157564137642.viewtracker-3.1.1.obr
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.annotation)(version>=2.5.2))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.apache.commons.logging)(version>=1.0.4)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.config)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.aop.support)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context.event)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.xml)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.config)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core.io)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.aop)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer.support)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.util.xml)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core.task)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.randombits.supplier.core)(version>=1.0.5))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.extender.event)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core.enums)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=com.atlassian.plugins.rest.common.security)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.util)(version>=2.5.0))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.context)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.apache.commons.logging)(version>=1.0.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=com.atlassian.templaterenderer)(version>=1.4.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.util)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.randombits.support.core.convert)(version>=1.2.5)(!(version>=1.3.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.propertyeditors)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.web.context.request)(version>=2.0.0))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core.io.support)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=com.atlassian.plugin.osgi.bridge.external))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory)(version>=2.0.0))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.context))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory)(version>=2.5.0))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.context.event)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (|(ee=J2SE-1.3))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory.support)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.context)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory)(version>=2.5.0)(!(version>=3.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.aop.framework)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.core.annotation)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.randombits.supplier.core.annotate)(version>=1.0.5))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.aopalliance.intercept))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.io)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.exporter.support)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer.event)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.aopalliance.aop))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.beans.factory)(version>=2.5.2))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer.event)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.scheduling.timer)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.service.importer.support)(version>=1.2.0)(!(version>=2.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context.support)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.util)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi.context.event)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.osgi)(version>=1.2.1)(version<=1.2.1))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:31,833 ERROR [UpmAsynchronousTaskManager:thread-1] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=org.springframework.context.support)(version>=2.5.6)(!(version>=4.0.0)))
-- url: /rest/plugins/1.0/ | referer: https://confluencetest.bsb.com/plugins/servlet/upm/marketplace/search?q=viewtracker | userName: scs
2015-07-24 09:50:32,037 WARN [UpmAsynchronousTaskManager:thread-1] [upm.core.install.DefaultPluginInstallationService] execute Plugin installation failed: Failed to resolve plugin dependencies within OBR [plugin.3846778157564137642.viewtracker-3.1.1.obr]. Please see the logs for more detailed information.

 

I've tried to clean the plugins cache and restart my instance but there is no difference.

 

The problem appeared first in version 5.5.7 when I've tried to remove Java 1.8 from my system and use only Java 1.7. it didn't work so I came back to version 1.8 (this was a test for my production environment).

Now that the system is back to version 1.8, it seems that this has messed up the UPM. But I have no clue of how to comme back to the normal state. Everything was working fine before.

Many thanks for your help.

Stephen

 

4 answers

1 accepted

1 vote
Accepted answer
Paulo Hennig Atlassian Team Jul 24, 2015

Hello Stephen,

I'm afraid you are being affected by this bug: https://ecosystem.atlassian.net/browse/UPM-5035

Could you follow the workaround (In your case, it's Confluence) described on the bug and update us with the results  ? 

 

 

Please note that we've suscribed to the Atlassian assistance until the end of the year. Many thanks.

Java 1.8 (system) Tomcat 6.0.32 running on Java 1.7 Confluence 5.6.6 UPM v 2.19.0

Hi Paulo,

many thanks for your assistance, you saved my life wink

I just had to clean the database for this to work, as after cleaning the last version of UPM was downladed by Confluence at startup. I had an entry in the database poiting on 2.19.

To help other people I let the SQL query I found on the Confluence wiki:


Select query:
select PLUGINDATAID , PLUGINKEY , FILENAME, LASTMODDATE from PLUGINDATA where pluginkey = 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' ;
Delete query:
delete from PLUGINDATA where PLUGINDATAID='XXXXXXXXX';
Hope everything will be fine now.
Regards,
Stephen

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,032 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you