It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Import docx fails (system error)

Any time I try to import a document to a space - i get the following:

 

Cause

org.springframework.orm.hibernate5.HibernateJdbcException: JDBC exception on Hibernate data access: SQLException for SQL [n/a]; SQL state [HY000]; error code [1366]; could not execute statement; nested exception is org.hibernate.exception.GenericJDBCException: could not execute statement
    at org.springframework.orm.hibernate5.SessionFactoryUtils.convertHibernateAccessException(SessionFactoryUtils.java:248)

caused by: org.hibernate.exception.GenericJDBCException: could not execute statement
    at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:47)

caused by: java.sql.SQLException: Incorrect string value: '\xF0\x9F\x98\x89</...' for column 'BODY' at row 1
    at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:965)

1 answer

0 votes

Gord,

Welcome to Atlassian Community! It's nice to have you.

Can you tell me the following:

  1. What version of Confluence are you running?
  2. What database version are you running Confluence on? Note: If you are on the embedded H2 database, at this time, you will need to migrate off of it onto a supported database. See Migrating to Another Database.
  3. Can you let us know exactly what you're trying to do? Are you attaching a document to a page in Confluence, or are you trying to create a page in a Confluence space using a Word document?
  4. What encoding are you using for Confluence and your database? See Troubleshooting Character Encodings for more details.
  5. Does this error occur for any documents?
  6. When did this last work?
  7. Does this occur in other spaces?

Thank you for your help!

Regards,

Shannon

Hi Shannon!

 

1. 6.15.4

2. Excellent Question - I built it a few months back, and likely left it on the embedded db. i'll check it out and migrate away if need be.

3. this answer is both - importing a document to a page, and creating a page with a doc, but fail on the same error.

4. I'm not sure which I'm using, but it does work (the link in my server)

5. I'll test others to be sure, but i've tried other versions of the same to no avail

6. I succeeded in june, and haven't had time to do much else with it since.

7. I will confirm later when time allows.

7. It fails on another space.

5. Seems to function on different documents.  Could this be caused by comments added (the bubbles) in Word?

Hi Gord, 

Thank you for the confirmation. So the other documents where it does NOT break, those do not have the comments added?

The error you were getting is usually caused by the embedded database, and since the embedded database is only meant to be used on evaluation instances during the initial evaluation period, you'll want to first migrate off of it to ensure that's not the issue.

My first recommendation to you would be to move off the H2DB. This will also ensure that your data is not lost if the database fails.

Regards,

Shannon

those broke too - I ended up copying and pasting to get the data in there... but then got another error:

Unable to communicate with server. Saving is not possible at the moment.

then immediately after:

"back in business"

 

On the database, how can I confirm which I'm running on? I am running it on Ubuntu 18.04 LTS, and have confirmed mySql is installed, suggesting that I did in fact actually convert when I put it into our production.

I think I have more issues than just this, but it could also be that I have issues with connectivity. I'm looking at this further

Update... fixed the "not available" issue - was caused by a winky smiley in the document I was working on... that's weird, but all good, it's fixed now. I'm going to assume the same import would succeed without the emoji in it... I might test it, but at this point since it's working, i'm going to leave it be.

 

thanks for the suggestions, appreciated!

Gord,

Thank you for confirming that you were able to fix the "not available" issue. You can check your database in your confluence.cfg.xml file:

I would check that even if you're able to fix the issue now; the embedded database doesn't work very well for production instances, and you run the risk of data loss if you remain on it.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

How To: get the most out of the new Confluence navigation and Home

Hi Community, Elaine again from Confluence Cloud Product Management. Most of you have used the new Confluence navigation and Home for some time by now. Not sure what changed or just want to lear...

480 views 3 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you