IMAP mailaccount configuration not found after upgrade Confluence to 4.2.1

Before the update (4.0.3) IMAP mailaccount worked fine. Now during startup in the log:

------------------------------

2012-04-28 12:49:00,147 WARN scheduler_Worker-5 confluence.setup.bandana.ConfluenceDaoBandanaPersister getObjectFromValue Configuration could not be loaded because class could not be found (context: wgt, key: atlassian.confluence.space.mailaccounts).

com.thoughtworks.xstream.converters.ConversionException: imapMailAccount : imapMailAccount

---- Debugging information ----

message : imapMailAccount : imapMailAccount

line number : 2

path : /list/imapMailAccount

cause-message : imapMailAccount : imapMailAccount

class : java.util.List

cause-exception : com.thoughtworks.xstream.alias.CannotResolveClassException

required-type : java.util.List

-------------------------------

And on the mail page of that space it shows:

No POP accounts have been configured for this space. (Add Mail Account)

I have not tried to see what happens if I enter the account-credentials again. Will do that as a 'last option'.

1 answer

1 accepted

0 votes
Accepted answer

Saw that you created a ticket on this. I'm currently reviewing it and will feedback to you from there.

I managed to reproduce the same issue and has raised a bug report on this at: https://jira.atlassian.com/browse/CONF-25457

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,174 views 20 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you