Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,829
Community Members
 
Community Events
165
Community Groups

I can't use the macro of "create from template pro" after I installed it

I found a strange issue yesterday about it will show an error message of "you need the app to access Atlassian products on your behalf after I installed the app of "Create from Template pro" , could someone help on it?04121.png

 

1 answer

2 votes
Sven Schatter _K15t_ Marketplace Partner Apr 12, 2022

Hi @Vincent-JS_Chen,

This is normal for apps built on the Atlassian Forge platform: you need to allow them access before you can starting using them.

It looks like you're trying to do that from the page editor. Unfortunately the Confluence Cloud editor does not allow interactions with macros. You'll have to save your page. When viewing the page you should then be able the click the "Allow access" button.

Hope this helps!

Cheers,
Sven

you need to allow them access before you can starting using them

<Vincent> Could you tell me how I can do to allow them to access my confluence?

 

When viewing the page you should then be able the click the "Allow access" button.

<Vincent> I didn't see "allow access" message in viewing mode?, here is snapshot for it.

 

04131.png

Sven Schatter _K15t_ Marketplace Partner Apr 12, 2022

It looks like you have already allowed the app access, as the "Create Project File Management" button is now rendered. So you're all set up and ready to go.

You only need to do this once, so the "Allow access" screen should not appear for you anymore - unless the app changes the permissions it uses at some point.

Other users in your system however may still have to click the "Allow access" button when they see the app for the first time, as for Forge apps this needs to be done by every user who wants to use the app.

Cheers,
Sven

sorry, you are right, I just found somehow I added old macro of "create from template", after I changed to "create from template pro", then I enabled it to access my site, now I am able to configure it, thanks for your help

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

322 views 2 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you