Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,669
Community Members
 
Community Events
165
Community Groups

How to remove an app that couldn't be loaded?

Edited

I have an oauth app, it worked well for years. but recently I don't know why it crashed, I tried to install an new version through uploading new jar file, it still crashed.

2022-05-28 21:13:19,551 ERROR [UpmAsynchronousTaskManager:thread-3] [atlassian.plugin.loaders.ScanningPluginLoader] deployPluginFromUnit Unable to deploy plugin 'com.miniorange.oauth.confluence-oauth' from 'Unit: /opt/atlassian/application-data/confluence/plugins-cache/1653743599177plugin_6437625575817779052_confluence-oauth-1.1.29.jar (1653743599000)'.
-- url: /rest/plugins/1.0/ | referer: https://mydomain.com/plugins/servlet/upm | traceId: 55fa3629cc16a651 | userName: ekbadmin
2022-05-28 21:13:19,551 ERROR [UpmAsynchronousTaskManager:thread-3] [atlassian.plugin.loaders.ScanningPluginLoader] deployPluginFromUnit Because of the following exception:
-- url: /rest/plugins/1.0/ | referer: https://mydomain.com/plugins/servlet/upm | traceId: 55fa3629cc16a651 | userName: ekbadmin
java.lang.NullPointerException
at com.atlassian.plugin.osgi.factory.transform.stage.HostComponentSpringStage.addHostComponentsUsedInSuperClasses(HostComponentSpringStage.java:225)
at com.atlassian.plugin.osgi.factory.transform.stage.HostComponentSpringStage.findUsedHostComponents(HostComponentSpringStage.java:210)
at com.atlassian.plugin.osgi.factory.transform.stage.HostComponentSpringStage.execute(HostComponentSpringStage.java:65)
at com.atlassian.plugin.osgi.factory.transform.DefaultPluginTransformer.transform(DefaultPluginTransformer.java:140)
at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.createOsgiPluginJar(OsgiPluginFactory.java:329)
at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:231)
at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:142)
at com.atlassian.plugin.loaders.ScanningPluginLoader.loadFoundPlugins(ScanningPluginLoader.java:111)
at com.atlassian.plugin.loaders.ForwardingPluginLoader.loadFoundPlugins(ForwardingPluginLoader.java:37)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)

 

error.PNG

2 answers

Hi @culyzhao,

Welcome to the community!

This is Akshay, and I'm from miniOrange, the vendor of OAuth app that you are using.

Since you are facing an issue to upload plugin JAR, could you please try to install the plugin from Find New Apps page of your Confluence server? If the issue still persists, you can reach out to miniOrange Support for further assistance.

You can raise a ticket with us, or you can also drop an email to info@xecurify.com. We will be happy to help you.


Thanks,
Akshay

0 votes
Srinatha T Atlassian Team May 28, 2022

Hi @culyzhao ,

Welcome to Atlassian community. 

If you are not able to remove the app from Manage apps then you will have to remove the jars. Follow the article which has the steps

I hope above info helps. Have a good day!

Thanks,

Srinath T

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

378 views 2 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you