How to change Base URL?

Hi,

I have been reading a lot of posts regarding how to change the Base URL but as I am quite new to this I allow myself to ask (to be on the safe side)

We have Confluence and JIRA installed on https://dev.<company>.com/confluence and https://dev.<company>.com/jira

We want to change the URL's to https://wiki.<company>.com and https://jira.<company>.com

As far as I can understand this is what I need to do. Correct?

  1. Change DNS
  2. Log in and change BASE URL's
  3. Edit server.xml

Do I need to edit the bandanakey aswell or would step 2 take care of that?

 

Thanks in advance!

 

Rgds

Thomas

3 answers

1 accepted

2 votes

That looks right to me, you do not need to mess with databases or anything like that.  DNS and the base url via the admin GUI are enough.

Except... if you have used application links, you'll want to update those as well (again via the gui).  And any other applications that are pointed to JIRA or Confluence.

Unfortunately I ran into some issues trying to do this now. I changed base url and removed application links between the two servers before starting. I also changed server.xml from the old to the new as shown below. When trying the new link https://wiki.<company>.com I just received a 404 from the old address https://dev.<company>.com/confluence (same for jira). We are using a Netscaler frontend which routes calls to our Nginx. Nginx has also been edited to reflect the change but no success I am afraid. Suggestions much appreciated.

&lt;Server port="8000" shutdown="SHUTDOWN" debug="0"&gt;
    &lt;Service name="Tomcat-Standalone"&gt;
        &lt;Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8090" minProcessors="5"
                   maxProcessors="75"
                   enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000"
                   SSLEnabled="false"
                   scheme="https"
                   secure="true"
                   proxyName="dev.&lt;company&gt;.com" 
                   proxyPort="443"
                   useURIValidationHack="false" URIEncoding="UTF-8"/&gt;

        &lt;Engine name="Standalone" defaultHost="localhost" debug="0"&gt;

            &lt;Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false"&gt;

                &lt;Context path="/confluence" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true"&gt;
                    &lt;!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties --&gt;
                    &lt;Manager pathname="" /&gt;
                &lt;/Context&gt;
            &lt;/Host&gt;

        &lt;/Engine&gt;
&lt;Server port="8000" shutdown="SHUTDOWN" debug="0"&gt;
    &lt;Service name="Tomcat-Standalone"&gt;
        &lt;Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8090" minProcessors="5"
                   maxProcessors="75"
                   enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000"
                   SSLEnabled="false"
                   scheme="https"
                   secure="true"
                   proxyName="wiki.&lt;company&gt;.com" 
                   proxyPort="443"
                   useURIValidationHack="false" URIEncoding="UTF-8"/&gt;

        &lt;Engine name="Standalone" defaultHost="localhost" debug="0"&gt;

            &lt;Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false"&gt;

                &lt;Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true"&gt;
                    &lt;!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties --&gt;
                    &lt;Manager pathname="" /&gt;
                &lt;/Context&gt;
            &lt;/Host&gt;

        &lt;/Engine&gt;

Found the error. I also had to edit this parameter in confluence.cfg.xml 

&lt;property name="confluence.webapp.context.path"&gt;/confluence&lt;/property&gt;

When changed to

&lt;property name="confluence.webapp.context.path"&gt;/&lt;/property&gt;

it all works smile

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Published 12 hours ago in Confluence

Think you know shares vs. @mentions in Confluence? Take this collab quiz.

To anyone who doubts that Atlassians are a little too obsessed with collaboration, and tools related thereto, let me describe a recent discussion we had (which took place on our internal Confluence, ...

95 views 2 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you