Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can I copy a complete diagram and then edit the copy only?

I have a diagram on a Confluence page. I want to copy that diagram to another page and then edit it there.

The "Duplicate" button works, but only when copying the diagram to the same page.

If I select an existing diagram after pressing "Insert - Diagram", I cannot edit it. There are 2 variations of this:

  • If I select "Link to diagram", it is just plain not editable.
  • If I click "Select" instead, the "Save" button in seems at first to let me save the diagram with a new name, but it also clears all content from the diagram.

So what I am stuck with is the complete inability to create an editable copy of a diagram. And actually I can't move a diagram from one Confluence page to another.

3 answers

Go to the page you want to insert the new diagram and insert a diagram from the insert menu. In the dialog that appears select "search" on the left:

Screen Shot 2015-06-02 at 19.14.28.png

search for the original diagram by name and then select it from the results. This will insert a clone of that original in that page.

The reason we do it this way only is to enforce a page revision to be created of that page, so it happens within the edit flow of that specific page.

It would also appear in the recent diagrams list if you changed it recently.

I understand the purist aspects in versioning of not offering a "Save as" function. But its not a reasonable reason for not including a basic function virtually universal in all other similar applications, it's not productive. 

Like # people like this

Fully agreed - it is as unproductive as pain in the neck to find basic functionality in circumventions !

What is your proposed flow of steps for implementing this?

I'm not in your source code, I was just exposing a basic need - duplication must be more straightforward as it is now. The proposes "make a copy" or "save as" directly from "file" menu. This is far more straightforward and convenient for the final user. 

But you need to insert a new macro onto the Confluence page, there needs to be a workflow (and a macro editor invoked). I don't understand how this straightforward process would work.

I understand the purist aspects in versioning of not offering a "Save as" function. But its not a reasonable reason for not including a basic function virtually universal in all other similar applications, it's not productive. 

Hi David,

Thank you for your answer. I have tried the method you describe several times, and just to make sure I tried it again now and recorded the exact steps I followed. Here is my result.

Steps taken:

  1. Click "Edit" on a confluence page
  2. In page editor, select "Insert"->" diagram"
  3. In popup, choose a diagram from "Recent diagrams" and click "Select".
  4. Diagram editor opens.
  5. Try to change something in the diagram - not possible, the diagram is not editable. I cannot insert shapes or move or edit shapes.
  6. Click "Save". A filename popup appears with default file name. Enter the new name "newtestDrawing1.xml" and click "Save"
  7. Diagram turns completely blank. All content is gone. In the top bar to the right of the "Help" menu, a text says "Error loading file"

So this procedure does not work for me. I hope you have a solution for this.

Yes, there seems to be a bug there, we've assigned an engineer to look at it. As a workaround for now, you can copy and paste a diagram within from the original to a new blank diagram to make a copy.

Thank you for fixing this. I am looking forward to an updated version without the bug. I don't think your workaround works. This is what I have done: 1. Open a blank diagram in a editor in one browser tab 2. Open an existing diagram in a editor in another browser tab. 3. In the existing diagram: "Edit->Select All" and "Edit->Copy" 4. In the new diagram: "Edit->Paste" <-- This menu item is greyed out and not working. I am using Firefox on Linux if that matters.

Use ctrl-C and ctrl-V instead of the edit menu for copy and paste. It's not technically possible to access the system clipboard from a browser using the menus.

Like Philip Chuang likes this

Ctrl+C and Ctrl+V works. Do you have a time estimate on when the bugfix will be rolled out? I am in the process of deploying Confluence to more users and I have to make a decision between Gliffy and I favour because of more advanced features, but I will be unable to defend that decision if basic functionality like copying a diagram just doesn't work.

It's marked as critical,, so it'll be in the next release. The release will probably out when it's fixed. It's hard to give an exact date, but it'll be during June.

Thanks for the update.

5.1.1 contains a fix for the issue. Please update to that. Thanks for the report.

I have updated and I can confirm that I can now create a new diagram from a copy of an existing diagram. Thank you for the fix. It came just in time for some demonstrations of the tool that I have coming up.

Hi David, After updating our plugin into evaluation license, All of my diagrams stills show with the “ evaluation copy” and I’m unable to edit them. But I can create new one and able to update the same..

@Mahendran Hi. Could you create a support request at detailing the problem. We'd need the Confluence version, current plugin version, plugin version you upgraded from(if any). Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

🏑 Atlympic Event: Confluence

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

524 views 18 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you