Has anyone experienced broken links upon upgrade to Confluence 4.0?

We just upgraded to Confluence 4 and are experiencing a weird bug. If we edit a page that contains links to other pages, when we click save, all links are changed to point to the page being edited.

This happens when we add a link in a comment, too. Add a comment, enter a link to another page. Save the comment, the link is changed to point to the page the comment is on.

Has anyone experienced this or does anyone have any ideas how to fix it?

1 answer

1 accepted

This had to do with useHttpOnly from:

<Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true> in server.xml

All is well now :-)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Published 8 hours ago in Confluence

Think you know shares vs. @mentions in Confluence? Take this collab quiz.

To anyone who doubts that Atlassians are a little too obsessed with collaboration, and tools related thereto, let me describe a recent discussion we had (which took place on our internal Confluence, ...

85 views 2 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you